none
VS2015 - Unable to connect to the configured development Web server

    Question

  • Initially, I was trying to test my website using an iPad and googled for ways to do that. After getting results from Stack Overflow and also some of the other websites, I tried different things to achieve that but did not have much luck. But, in trying those different things I broke how my website was running using a browser. Now, whenever I try to run it using a browser,  I get this error:

    "Unable to connect to the configured development Web server."

    The type of the project that I have is "Web Site". 

    I have tried the following:

    1. Deleted C:\Users\[Me]\Documents\IISExpress folder

    2. Deleted applicationhost.config under .vs directory in the solution directory

    3. Deleted the .vs directory

    4. Ran

    netsh http add urlacl url=http://{ip_addr}:{port}/ user=everyone

    5. Restarted Visual Studio several times

    6. Restarted machine several times

    7. Uninstalled Visual Studio 2015 (Professional edition) and IISExpress 10.

    8. Reinstalled Visual Studio (which reinstalled IISExpress 10)

    Any help is appreciated. 





    • Edited by Debarupa Monday, February 11, 2019 5:38 PM
    Friday, February 8, 2019 11:43 PM

Answers

  • The problem has been fixed.

    Yes, I tried other browsers and rebooted the machine several times with no luck.

    The fix was to add 0.0.0.0 to the IP listen list per https://stackoverflow.com/questions/32190881/how-to-solve-err-connection-refused-when-trying-to-connect-to-localhost-running/45199591#45199591

    netsh http add iplisten ipaddress=0.0.0.0

    in the command prompt running as administrator.

    Thanks for all your help.

    • Marked as answer by Debarupa Tuesday, February 12, 2019 4:00 PM
    Tuesday, February 12, 2019 3:55 PM

All replies

  • Hi Debarupa,

    Welcome to the MSDN forum.

    >> Now, whenever I try to run it using a browser,  I get this error:

    Do you meet this issue for other website applications? Please try to create a new website application and confirm this issue occurs or not.

    According to the error message, please have a try with the following:

    1. Run VS as administrator
    2. Right click the project name, Properties-Server and change the project URL to other port
    3. Delete the temporary ASP.NET Files located: C:\WINDOWS\Microsoft.NET\Framework\v4.0. 30319\Temporary ASP.NET Files\root

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, February 11, 2019 7:08 AM
    Moderator
  • >>Do you meet this issue for other website applications? Please try to create a new website application and confirm this issue occurs or not.

    Yes, I created a new website and tried to run it using the browser and the same error popped up.

    >>According to the error message, please have a try with the following:

    1. Run VS as administrator
    2. Right click the project name, Properties-Server and change the project URL to other port
    3. Delete the temporary ASP.NET Files located: C:\WINDOWS\Microsoft.NET\Framework\v4.0. 30319\Temporary ASP.NET Files\root

    Here's what I did:

    1. Ran VS as administrator

    2. Right clicked the project name, Properies, but there is no "Server" and the project URL port cannot be changed as they are disabled in both "URL" and "Opened URL" settings. Please note that mine is a web site not a web application.

    3. deleted the temporary ASP.NET Files as mentioned.

    Still see the same error.



    • Edited by Debarupa Monday, February 11, 2019 8:58 PM
    Monday, February 11, 2019 5:31 PM
  • Hi Debarupa,

    Thank you for your update.

    Have you tried use other browser and this issue persists or not? 

    Meanwhile, we can reboot the computer and try it again.

    After the error message "Unable to connect to the configured development Web server", there have more error information or not?

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, February 12, 2019 9:50 AM
    Moderator
  • The problem has been fixed.

    Yes, I tried other browsers and rebooted the machine several times with no luck.

    The fix was to add 0.0.0.0 to the IP listen list per https://stackoverflow.com/questions/32190881/how-to-solve-err-connection-refused-when-trying-to-connect-to-localhost-running/45199591#45199591

    netsh http add iplisten ipaddress=0.0.0.0

    in the command prompt running as administrator.

    Thanks for all your help.

    • Marked as answer by Debarupa Tuesday, February 12, 2019 4:00 PM
    Tuesday, February 12, 2019 3:55 PM
  • Hi Debarupa,

    We are so glad to hear that your issue is solved and thank you for your sharing, that will benefit for other community members.

    If you have any other VS IDE issues in the future, please feel free to let us know.

    Have a nice day!

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, February 13, 2019 2:18 AM
    Moderator