none
Internal error while compiling a project

    Question

  • Hello,

    I'm using Visual Studio 2015 community edition and when trying to compile a project, I get the following message:

    - An internal error has occurred in the compiler.

    Is it possible to send the project to Microsoft? It's a serious issue and Visual Studio would benefit from fixing it in a future version.

    Thanks,
    Mark

    Saturday, October 08, 2016 8:22 PM

All replies

  • Hi Mark,

    Yes, send it to Microsoft using Microsoft Connect:

    https://connect.microsoft.com


    My portal and blog about VSX: http://www.visualstudioextensibility.com
    Twitter: https://twitter.com/VSExtensibility
    MZ-Tools productivity extension for Visual Studio: http://www.mztools.com

    Sunday, October 09, 2016 6:38 AM
  • Thank you Carlos, I have submitted the problem there. It's a pity that Microsoft does not directly reference this website in Visual Studio support website...
    Sunday, October 09, 2016 8:49 AM
  • If the problem is specific to the C# or VB.NET compilers of VS 2015 ("Roslyn") it is even better to submit it as an Issue at Github:

    https://github.com/dotnet/roslyn/issues


    My portal and blog about VSX: http://www.visualstudioextensibility.com
    Twitter: https://twitter.com/VSExtensibility
    MZ-Tools productivity extension for Visual Studio: http://www.mztools.com

    Sunday, October 09, 2016 10:05 AM
  • Thanks for the link, but the problem occurs in a C++ project. Since I can't isolate the bug, I had to submit the full project for investigation.
    Sunday, October 09, 2016 12:23 PM
  • Hi Mark,

    Please share me which type C++ project you have created, which could help me to repro your issue in my side.

    Please refer to the following steps to troubleshot this issue:

    1). Please create a new c++ project and compile it to observe whether has the same issue. If not, the issue may be related to a specify project, please share me the code snippets. If yes, this may be related to the VS, please update the VS to the latest version 14.0.25431.01 Update3. Here are the steps: Tools-> Extensions and Updates -> Updates -> update option that beginning with “KB” letters.

    2). Disable optimization, right click the project -> Properties -> Configuration Properties -> C/C++ -> Optimization -> Optimization = Disabled. This is the /Od compiler switch.

    Sincerely,

    Oscar


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    Tuesday, October 11, 2016 5:11 AM
    Moderator