locked
Getting 404 error while fetching authentication token and refresh token? RRS feed

  • Question

  • I am trying fetch authentication token and refresh token but each time I got following error.

    <HTTP::Response/1.1 404 Not Found {"Server"=>"Microsoft-IIS/8.5", "X-Content-Type-Options"=>"nosniff", "Strict-Transport-Security"=>"max-age=31536000", "X-Xss-Protection"=>"1; mode=block", "Date"=>"Wed, 31 Aug 2016 05:43:36 GMT", "Connection"=>"close", "Content-Length"=>"0"}>

    I am using Ruby Gem and also tried on rest console extension.

    HTTP.headers(:accept => "application/json", :content_type => "application/x-www-form-urlencoded", :host => "login.live.com", :content_length => 167).post("https://login.live.com/oauth20_token.srf HTTP/1.1", :body => "client_id=5f48149d-0429-4994-ba82-feaf0fae6bb9&code=M60bf582e-e097-6e41-cdbc-7d60ab3734f6&grant_type=authorization_code&client_secret=MY_SECRET_CODE&redirect_uri=https%3A%2F%2Fdev1.promocodesforyou.com%2Fapi%2Fbing_callback")

    I have also tried buy sending params in query string and as form data. Please help me on this issue.

    Wednesday, August 31, 2016 6:05 AM

All replies

  • I don't have a Ruby environment setup. Will you please provide more details about how to repro e.g. setup your Ruby dev environment? I've read that Ruby >= 2.0.0 uses SSL by default, and otherwise you might need to set "use_ssl". I wonder if that could be related.

    Thank you,

    Eric

    Wednesday, August 31, 2016 4:19 PM