locked
Can't install Xamarin.Android.Support.v7.AppCompat RRS feed

  • Question

  • User282601 posted

    Whenever I try to install Xamarin.Android.Support.v7.AppCompat with "Components" (on Visual Studio) nothing appears on references and in the "Edit Components" page it says that Xamarin.Android.Support.v7.AppCompat component is missing Xamarin.Android.Support.v7.AppCompat...

    And whenever I try to install it via Nuget, I get the following error:

    Could not install package 'Xamarin.Android.Support.Compat 24.2.1'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v5.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

    Friday, December 9, 2016 7:21 PM

Answers

  • User180523 posted

    @ErenKara

    You're not getting it. Let me try saying it differently. Ignore what it is saying about those needing to be updated. It lies. They don't need to be updated. Xamarin.Forms will get what it needs.

    It is a false report that they need to be updated due to a change in version number schemes. The version numbers went from 3 digits to 4 and caused this behavior where you get told there are updates but their really aren't ones that apply to you.

    Those support updates aren't for Xamarin.Forms 2.anything. Ignore them.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, December 9, 2016 9:12 PM

All replies

  • User180523 posted

    You shouldn't be trying to update those.

    Friday, December 9, 2016 7:24 PM
  • User282601 posted

    @ClintStLaurent said: You shouldn't be trying to update those.

    Oh! I was trying to get v7.AppCompat without installing Xamarin.Forms first... But still, I can't use it because the AppCompat is version 23.3.0 and the component requires latest version.

    Friday, December 9, 2016 7:36 PM
  • User180523 posted

    @ErenKara Just update your Xamarin.Forms. It will grab the Android.Support.xxx versions it needs AND WORKS WITH.

    Friday, December 9, 2016 8:00 PM
  • User282601 posted

    @ClintStLaurent said: @ErenKara Just update your Xamarin.Forms. It will grab the Android.Support.xxx versions it needs AND WORKS WITH.

    Xamarin.Forms is already updated. But the Android.Support packages are still-not-updated.

    Friday, December 9, 2016 8:38 PM
  • User180523 posted

    @ErenKara

    You're not getting it. Let me try saying it differently. Ignore what it is saying about those needing to be updated. It lies. They don't need to be updated. Xamarin.Forms will get what it needs.

    It is a false report that they need to be updated due to a change in version number schemes. The version numbers went from 3 digits to 4 and caused this behavior where you get told there are updates but their really aren't ones that apply to you.

    Those support updates aren't for Xamarin.Forms 2.anything. Ignore them.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, December 9, 2016 9:12 PM