none
Unable to open Remote tools with static IP?? RRS feed

  • Question

  • Hello Friends,

    I have configured Static IP after adding entries in  cpsw3gMiniport.reg under

    [HKEY_LOCAL_MACHINE\Comm\CPSW3G1\Parms\TcpIp]
        "EnableDHCP"=dword:0
        "DefaultGateway"="192.168.1.1"
        "UseZeroBroadcast"=dword:0
        "IpAddress"="192.168.1.98"
        "Subnetmask"="255.255.255.0"
        "DNS"="192.168.0.1"

    And I am getting same IP when I ping from host machinewith Diable KITL true..

    But when I open the Rermote tools like Reg Editor, I got an error as unable to open.??????

    As, I also made changes here -

    cpgMacKitlMiniport.reg

    [HKEY_LOCAL_MACHINE\Comm\CPSW3G1\Parms\TcpIp]
        "EnableDHCP"=dword:1
        "DefaultGateway"="192.168.1.1"
        "UseZeroBroadcast"=dword:0
        "IpAddress"="192.168.1.48"
        "Subnetmask"="255.255.255.0"
        "DNS"="192.168.1.1"
        "Domain"=""

    cpgMacMiniport.reg

    [HKEY_LOCAL_MACHINE\Comm\CPSW3G1\Parms\TcpIp]
        "EnableDHCP"=dword:0
        "DefaultGateway"="192.168.1.1"
        "UseZeroBroadcast"=dword:0
        "IpAddress"="192.168.1.99"
        "Subnetmask"="255.255.255.0"
        "DNS"="192.168.0.92"
        "Domain"=""
    

    What Should I do so that remote tools also work with static IP?????

    Thursday, October 16, 2014 7:35 AM

All replies

  • You have one device and three REG files? Frankly, that's beyond my horizon.

    You should make it step by step. Remote Tools utilite CoreCon, CoreCon utilizes TCP, TCP -> IP, IP->Ethernet, Ethernet->Hardware. So when you have plugged in the cable, you should verify that you know, that the device's network adapter has an IP address and you should know what IP address.  A simple test is the "ping" command.

    When ping gives useful result stop fiddling with IP configuration.

    If you have a Telnet server at the device you can connect the device and start ConManclient3.exe and CMAccept3.exe.

    If you have a KITL connection to Platform Builder you can do the same here.

    If you have no connection to start a process you have to make sure that the ConManClient3.exe is running. CMAccept3.exe may stop after a while. In the latest case you should consider to set CoreConOverrideSecurity in your registry.

    • Proposed as answer by Harper23 Friday, October 17, 2014 6:53 AM
    Friday, October 17, 2014 6:50 AM