locked
Vista Business Classic ASP Error when viewing in Browser RRS feed

  • Question

  • User-1648364792 posted

    I use Microsoft Expressions to design web sites. Until recently I was using XP Professional as the OS and all was well.

    I have now installed Vista Business and everything works until I try to view an ASP page in the browser, I then get an error message - THIS PAGE MAY CONTAIN DYNAMIC CONTENT THAT REQUIRES A WEB SERVER IN ORDER TO PREVIEW CORRECTLY -.I am then shown the code content only.

    ASP is activated on my machine

    HTML shows up in the browser without a problem

    Any advice please

     

    kind regards

    Tuesday, January 29, 2008 2:45 AM

Answers

  • User511787461 posted

    Design view is just rendered by expression - has nothing to do with asp working.

    Can you list the output of "%windir%\system32\inetsrv\appcmd.exe list config -section:system.webServer/handlers" and collect failed request trace for the asp request in question and paste the trace output.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, February 1, 2008 3:43 AM

All replies

  • User989702501 posted

    Don't think this is IIS or ASP error page, mostly the code. can you try a simple hello.asp ?

    Tuesday, January 29, 2008 2:47 AM
  • User-1648364792 posted

    Thanks for your reply Bernard.

    Yes - the Hello ASP works - I can see it in the design tab  - It's only when I want to view in browser that the problem arises.

    The problem is not confined to one site alone - all of them react in the same way, and they all worked without a problem with XP.

     

    rgds

     

    misafi

    Tuesday, January 29, 2008 3:31 AM
  • User989702501 posted

    I don't know about expression. so if IIS is working on simple hello.asp. then you might want to visit expression newsgroup or forum on the configuration.

    Thursday, January 31, 2008 11:42 PM
  • User-1648364792 posted

    Thanks for trying qbernard.

    I have, and I've searched every Blog that I can find - some similar questions are there, but no answers.

    I think that it may have to do with permissions, but there again, I've turned evry option on that I can find.

    I seems crazy to think that I will need to revert to XP, but that seems my only option.

     

    kind regards

     

    Misafi

     

    Thursday, January 31, 2008 11:55 PM
  • User511787461 posted

    It is not clear from your statement, is hello asp working from the browser?

    Friday, February 1, 2008 2:26 AM
  • User-1648364792 posted

     

    No - not from the browser,  but it works in design view so presumably ASP is working in the system.

     

    regards

     

    Misafi

    Friday, February 1, 2008 2:47 AM
  • User511787461 posted

    Design view is just rendered by expression - has nothing to do with asp working.

    Can you list the output of "%windir%\system32\inetsrv\appcmd.exe list config -section:system.webServer/handlers" and collect failed request trace for the asp request in question and paste the trace output.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, February 1, 2008 3:43 AM
  • User-1648364792 posted

    Thanks.

    I did this in the command prompt, is that correct? -  and if so is there not a command that I have to run first to ensure that I am recognised as the Administrator.

    This is what I entered

    %windir%\system32\inetsrv\appcmd.exe list config -section:system.webServer/handlers

    Response

    Quote

    Configuration Error

    Filename:\\?|C:windows\system32\inetsrv\config\applicationHost.config

    Lime number : 0

    Cannot read configuration file.

    Unquote

     

    rgds

     

     

    Friday, February 1, 2008 4:40 AM
  • User511787461 posted

    Run it from an elevated command prompt - also the failed request trace log

    Friday, February 1, 2008 1:11 PM
  • User-1648364792 posted

    Hi Anil

     I ran it in the elevated command prompt - but I'm sorry to say, I was uanabel to access the failed request trace log.

    In my IIS manager I followed all the required steps to activate trace logging until I got to "Configure" in the Default Web site then I could go no further.

    This is the result of my elevated command efforts.

    Microsoft Windows [Version 6.0.6000]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>%windir%\system32\inetsrv\appcmd.exe list config -section:sy
    stem.webserver/handlers
    <system.webServer>
      <handlers accessPolicy="Script, Read">
        <add name="TraceHandler-Integrated" path="trace.axd" verb="GET,HEAD,POST,DEB
    UG" type="System.Web.Handlers.TraceHandler" preCondition="integratedMode" />
        <add name="WebAdminHandler-Integrated" path="WebAdmin.axd" verb="GET,DEBUG"
    type="System.Web.Handlers.WebAdminHandler" preCondition="integratedMode" />
        <add name="AssemblyResourceLoader-Integrated" path="WebResource.axd" verb="G
    ET,DEBUG" type="System.Web.Handlers.AssemblyResourceLoader" preCondition="integr
    atedMode" />
        <add name="PageHandlerFactory-Integrated" path="*.aspx" verb="GET,HEAD,POST,
    DEBUG" type="System.Web.UI.PageHandlerFactory" preCondition="integratedMode" />
        <add name="SimpleHandlerFactory-Integrated" path="*.ashx" verb="GET,HEAD,POS
    T,DEBUG" type="System.Web.UI.SimpleHandlerFactory" preCondition="integratedMode"
     />
        <add name="WebServiceHandlerFactory-Integrated" path="*.asmx" verb="GET,HEAD
    ,POST,DEBUG" type="System.Web.Services.Protocols.WebServiceHandlerFactory, Syste
    m.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3
    a" preCondition="integratedMode" />
        <add name="HttpRemotingHandlerFactory-rem-Integrated" path="*.rem" verb="GET
    ,HEAD,POST,DEBUG" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHandle
    rFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKeyTo
    ken=b77a5c561934e089" preCondition="integratedMode" />
        <add name="HttpRemotingHandlerFactory-soap-Integrated" path="*.soap" verb="G
    ET,HEAD,POST,DEBUG" type="System.Runtime.Remoting.Channels.Http.HttpRemotingHand
    lerFactory, System.Runtime.Remoting, Version=2.0.0.0, Culture=neutral, PublicKey
    Token=b77a5c561934e089" preCondition="integratedMode" />
        <add name="AXD-ISAPI-2.0" path="*.axd" verb="GET,HEAD,POST,DEBUG" modules="I
    sapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_
    isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness32" responseBuffe
    rLimit="0" />
        <add name="PageHandlerFactory-ISAPI-2.0" path="*.aspx" verb="GET,HEAD,POST,D
    EBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v2
    .0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitness3
    2" responseBufferLimit="0" />
        <add name="SimpleHandlerFactory-ISAPI-2.0" path="*.ashx" verb="GET,HEAD,POST
    ,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\
    v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bitnes
    s32" responseBufferLimit="0" />
        <add name="WebServiceHandlerFactory-ISAPI-2.0" path="*.asmx" verb="GET,HEAD,
    POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framew
    ork\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2.0,bi
    tness32" responseBufferLimit="0" />
        <add name="HttpRemotingHandlerFactory-rem-ISAPI-2.0" path="*.rem" verb="GET,
    HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\F
    ramework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv2
    .0,bitness32" responseBufferLimit="0" />
        <add name="HttpRemotingHandlerFactory-soap-ISAPI-2.0" path="*.soap" verb="GE
    T,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET
    \Framework\v2.0.50727\aspnet_isapi.dll" preCondition="classicMode,runtimeVersion
    v2.0,bitness32" responseBufferLimit="0" />
        <add name="SSINC-stm" path="*.stm" verb="GET,POST" modules="ServerSideInclud
    eModule" resourceType="File" />
        <add name="SSINC-shtm" path="*.shtm" verb="GET,POST" modules="ServerSideIncl
    udeModule" resourceType="File" />
        <add name="SSINC-shtml" path="*.shtml" verb="GET,POST" modules="ServerSideIn
    cludeModule" resourceType="File" />
        <add name="ASPClassic" path="*.asp" verb="GET,HEAD,POST" modules="IsapiModul
    e" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="File" />
        <add name="SecurityCertificate" path="*.cer" verb="GET,HEAD,POST" modules="I
    sapiModule" scriptProcessor="%windir%\system32\inetsrv\asp.dll" resourceType="Fi
    le" />
        <add name="TRACEVerbHandler" path="*" verb="TRACE" modules="ProtocolSupportM
    odule" requireAccess="None" />
        <add name="OPTIONSVerbHandler" path="*" verb="OPTIONS" modules="ProtocolSupp
    ortModule" requireAccess="None" />
        <add name="ISAPI-dll" path="*.dll" verb="*" modules="IsapiModule" resourceTy
    pe="File" requireAccess="Execute" allowPathInfo="true" />
        <add name="CGI-exe" path="*.exe" verb="*" modules="CgiModule" resourceType="
    File" requireAccess="Execute" allowPathInfo="true" />
        <add name="StaticFile" path="*" verb="*" modules="StaticFileModule,DefaultDo
    cumentModule,DirectoryListingModule" resourceType="Either" requireAccess="Read"
    />
      </handlers>
    </system.webServer>

    C:\Windows\system32>

     

    kind regards

     

    Sean Minogue

    Misafi

     

    Saturday, February 2, 2008 3:17 AM
  • User511787461 posted

    What error did you get trying to configure failed request tracing?

    The *.asp mapping is present below - so unless it is remove'd/clear'ed at a lower level in heirarchy - we need freb trace to see what is going on.

    Monday, February 4, 2008 2:07 PM
  • User-1648364792 posted

    Hi Anil

    I'm afraid that I'm showing my inexperience with Vista here - I went through the steps - so I thought - to configure request tracing, but I obviously didn't do it correctly.

    I got no error message  - I just got a section showing "configure" but when I clicked on it nothing showed up - I was at a dead end.

     

    rgds

    Monday, February 4, 2008 2:27 PM
  • User511787461 posted

    I still don't know where you are getting stuck - so here is how I would enable freb.

    Use the tree view to go down to the web-site you are interested in - choose "advanced settings" in the right action pane - expand "failed request tracing", change enabled to true and click ok.  Now find the "failed request tracing rules" in the list of features in the middle pane, double click to open it and click add on the right action pane, on the wizard that comes up, choose "all content *" in the first screen, click next, on the next screen choose "status code..." and type 200 and click next - choose all providers (if not already done) with verbosity verbose and click finish.

    Now make the request and find the trace log file under \Inetpub\logs\FailedRequestLogging\w3svc<n>

    Tuesday, February 5, 2008 3:43 PM
  • User-1648364792 posted

    There is obviously something wrong with my set up.

    When I follow your instructions in IIS Manager I get to Advanced settings and all it shows is

    General with Bindings - ID - Name - Physical path - physical path credentials  - physical path credentials log on - and Start Automaticaly.

    Behaviour with Application Pool - connection limits

    Connection Limits show - Time out - Max bandwidth - max concurrent connection

    I have checked the logs folder in Inetpub but no FailedRequestLogging.

     

    kind regards

    Wednesday, February 6, 2008 12:47 AM
  • User511787461 posted

    You probably do not have the IIS tracing feature installed - go to control panel -> programs and features -> windows features and install it (somewhere under IIS in there).

    Wednesday, February 6, 2008 5:31 AM
  • User-1648364792 posted

    Thanks Anil

    I've activated every darned logging aspect in site including tracing.

    Now I'll go back to your initial instructions - it's late here now so I'll get back to you tomorrow.

    Thank you very much for your patience - it's much appreciated.

    kind regards

     

    Wednesday, February 6, 2008 2:09 PM
  • User-1648364792 posted

    Good Morning Anil

    The FailedRequestLogging is enabled and pointed to the correct folder in inetpub.

    I followed your instructions as to the advanced setting.

    The folder is now present but when I activate your script it remains empty.

    Here is the last attempt.

    C:\Users\Sean>%windir%\system32\inetsrv\appcmd.exe list config -section:system.w
    ebServer/handlers
    ERROR ( message:Configuration error
    Filename: \\?\C:\Windows\system32\inetsrv\config\applicationHost.config
    Line Number: 0
    Description: Cannot read configuration file
    . )

     

    rgds

    Sean

    Thursday, February 7, 2008 4:07 AM
  • User511787461 posted

    You already provided me the output of that command (btw, you need to run it from an elevated command prompt).

    Now that you have enabled failed request tracing, just browse to an asp page and you should see a frnnn.xml file in the freb folder - open the file in IE, click on compact view and cut-n-paste the trace events to this thread.

    Thursday, February 7, 2008 7:12 PM
  • User-1648364792 posted

    Thanks Anil

    I am now able to access the freb file - problem is that when I save it as a text file - I can't find any other way of compacting it - the file size is 184 k and the system hangs every time I try to cut and paste to this thread.

    Is ther any way that I can send you the text file itself?

     rgds

    Sean

    Friday, February 8, 2008 12:22 AM
  • User511787461 posted

    You can e-mail it to me at anil (dot) ruia (at) microsoft (dot) com

    Friday, February 8, 2008 12:57 PM