locked
Sharepoint Export to Excel not working RRS feed

  • Question

  • I am attempting to Export a SharePoint list to Excel from a site where I am an Owner of the site.   I've been able to do this before, but have upgraded to Office 2010 and WIN 7 since.   Others are able to export from the same list so it doesn't appear to be associated with the list in use.   FWIW, here are some specifics:

    • Office 2010 32 Bit
    • Windows 7 32 Bit
    • SharePoint admin can download the specific list to Excel. 
    • When I click on Download to excel I see the message box that states "DO YOU WANT TO OPEN OR SAVE".  I click on open.  The file name is owssvr.iqy.  
    • When I click on OPEN, nothing happens.  If Excel is closed, Excel opens.  If Excel is open, no additional file is opened.  

    Thanks for your assistance. 

    Barb Reinhardt

    Monday, October 7, 2013 1:03 PM

Answers

  • For some reason I didn't get this reply by email, but we'd tried all of those things before I posted my query.   What ended up fixing it was to "move my windows profile"   Now I'm working to get everything set back up the way I like it.  

    Thursday, October 10, 2013 5:20 PM

All replies

  • Hi Barb,

    Based  on your description, this issue occurred on the client server. After  you upgraded office to 2010 and your OS to Win 7, the issue occurred .

    For resolving your issue, please check the followings:
     1.Open IE, click Tools
     2.Select  Internet Options
     3.Click Programs->Manage add-ons
     4.Show : All add-ons, Scroll to check whether all add-ons related to SharePoint and Office are enable, such as SharePoint OpenDocuments Class. If  not, please enable them

    But if the SharePoint OpenDocuments Class isn’t listed in the collection of add-ons on your machine, you can try to fix it with the following steps. Cause it’s possible that the add-on does exist somewhere but that it wasn’t updated when recent Office upgrades were installed on your computer.
     
     1.From the Start menu, click Control Panel, and then click Programs.
     2.On the Control Panel Programs page, click Programs and Features.
     3.Scroll down the list of installed programs, select Microsoft Office, and then click Change.
     4.In the Change dialog, click Repair and then click Continue.
     
    Little interaction is required from you until the repair operation is complete. At that time, you might need to reboot your computer so the changes can take effect.

    When your computer finishes rebooting, go back into Internet Explorer and repeat the procedure for enabling the add-on.

    I  hope this helps.

    Thanks,

    Wendy


    Wendy Li
    TechNet Community Support

    Tuesday, October 8, 2013 9:25 AM
  • For some reason I didn't get this reply by email, but we'd tried all of those things before I posted my query.   What ended up fixing it was to "move my windows profile"   Now I'm working to get everything set back up the way I like it.  

    Thursday, October 10, 2013 5:20 PM
  • Hello Wendy,

    I have the same situation and I would like to know if this is applicable since the machine have the 

    MS Office Professional Plus 2013 ?

    Thanks,

    Paulo

    Monday, September 21, 2015 7:59 PM