locked
Links show code page instead of design page when uploaded to server. RRS feed

  • Question

  • As a practice exercise, I imported my company's website into EW 4 and made some minor changes. It previews as a fully functional website in the browser, but after uploading it to my web host, all of the internal links display the code only when I try to navigate the site. All of the internal links point to my C: drive instead of where they are supposed to go. I think this has something to do with relative paths instead of absolute paths, but I am not sure how I am supposed to fix this.


    • Edited by bwhobby Friday, October 7, 2011 9:26 PM
    Friday, October 7, 2011 9:15 PM

Answers

  • Does your server support ASP.NET?

    That's not as off the wall as it may sound. We have had people in here before who were trying to run an ASP.NET site on a Linux server that doesn't support it. Gotta ask.


    The Dalai Lama walks into a pizza shop and asks the guy behind the counter, "Can you make me one with everything?"
    • Marked as answer by bwhobby Tuesday, October 11, 2011 11:38 AM
    Saturday, October 8, 2011 10:00 PM
  • Problem solved! The issue was the proper Windows hosting environment and deploying the website with the associated SQL database. I downloaded the free Microsoft Web Matrix program, used a recommended web host contained with in the program, and downloaded the publishing settings from the web host into the program. All I had to do after that was open my web site files with the program, click on publish, and everything after that was automatic. Thanks again for all the help.
    • Marked as answer by bwhobby Tuesday, October 11, 2011 11:39 AM
    • Edited by bwhobby Tuesday, October 11, 2011 11:43 AM
    Tuesday, October 11, 2011 11:37 AM

All replies

  • Typically you only see the file path issue when you work outside of defined site such as by using File > Open > [page] instead of Site > Open Site and then opening the pages from the Folder List menu.

    You will need to fix it by opening the site locally correctly, make sure Site > Site Settings and that "use meta data" is enabled. You can try recalculating hyperlinks and see if that fixes the file system references, if not you may have to either use find/replace or open the hyperlink dialog box and navigating to the correct page inside the open site to create a new properly referenced link.


    Free Expression Web Tutorials
    For an Expression Web forum with without the posting issues try expressionwebforum.com
    Friday, October 7, 2011 9:49 PM
  • Did you create a new empty web to import the company site into BEFORE you imported it.
    If not EW doesn't see  it as a web site and therefore doesn't create relative links.

    As for code only, what kind of site is it?
    Are the pages .asp files or .html files?


    Expression Web MVP
    Saturday, October 8, 2011 5:49 PM
  • Yes, I created a new empty website and then imported the site into it. I then uploaded it to my web server and I still get references to my C: drive. I am showing broken links for WebResource.axd and ScriptResource.axd. These show: web form post back options, Microsoft ajax debug.js, and Microsoft Ajax Web Forms debug.js. The files have aspx extensions so I am assuming they are asp files. Thank you for your help.
    Saturday, October 8, 2011 8:02 PM
  • I opened the site via site settings, recalculated the hyperlinks, and am showing broken links for webresources.axd and scriptresources.axd which are links to lengthy scripts.  However, I can't create hyperlinks to the script pages I created because the hyperlink icon is grayed out and is not active. I am guessing this might be the problem. Thank you for your help
    Saturday, October 8, 2011 8:32 PM
  • Does your server support ASP.NET?

    That's not as off the wall as it may sound. We have had people in here before who were trying to run an ASP.NET site on a Linux server that doesn't support it. Gotta ask.


    The Dalai Lama walks into a pizza shop and asks the guy behind the counter, "Can you make me one with everything?"
    • Marked as answer by bwhobby Tuesday, October 11, 2011 11:38 AM
    Saturday, October 8, 2011 10:00 PM
  • "However, I can't create hyperlinks to the script pages I created because the hyperlink icon is grayed out"

    You don't have to use the hyperlink icon.  Type the correct links in the code.

    As to why the hyperlink icon is greyed out: on what type of page?

    Saturday, October 8, 2011 10:07 PM
  • Bill,

    The OP is talking about a functioning, hosted website, and is talking about hyperlinks on the imported (should have been published down, not imported, by the way) and then re-published site.

    ...How would that relate to running asp.net on the host?  If it was functioning asp.net site....

    Sunday, October 9, 2011 1:33 AM
  • Sorry. Twice, both yesterday and today, I read "...all of the internal links display the code only when I try to navigate the site" and thought that only code was displaying instead of the proper page. Otherwise how would the OP be seeing the code on the site?

    That may not be what the OP meant, but that is still about the foggiest sentence imaginable.

    Then I read this afternoon's post: "The files have aspx extensions so I am assuming they are asp files.", which was not something the OP had previously mentioned and I connected the two. To post a site to the web server without being sure even what kind of files they are seemed careless enough that it begged the question of whether the server supported ASP.NET. If it was a functioning site, of course, the server would support aspx files. But how then does the OP see code only when navigating?

    Sure would be nice if the OP were clearer about everything and had posted a link to the site as it states in the Forum FAQ.


    The Dalai Lama walks into a pizza shop and asks the guy behind the counter, "Can you make me one with everything?"
    Sunday, October 9, 2011 2:20 AM
  • I agee that "display code only" could be taken as pages not processed by asp.net, and assuming .aspx pages are asp - no, asp.net, not asp, two different things - makes it hard to guess what the OP meant, but the first two posts from the OP in combination seem to be talking about links referencing the C drive as the issue, and, again, references a functioning site.


    Adding: Since the OP was very unclear, that "display code only" could be a reference to local previewing, which would simply be a matter of linking to an asp.net page from an html page without having set the preview options to preview all pages with the development server, but the post does read as it being a hosted site issue.  <shrug>
    • Edited by KathyW2 Sunday, October 9, 2011 3:17 PM
    Sunday, October 9, 2011 4:15 AM
  • Problem solved! The issue was the proper Windows hosting environment and deploying the website with the associated SQL database. I downloaded the free Microsoft Web Matrix program, used a recommended web host contained with in the program, and downloaded the publishing settings from the web host into the program. All I had to do after that was open my web site files with the program, click on publish, and everything after that was automatic. Thanks again for all the help.
    • Marked as answer by bwhobby Tuesday, October 11, 2011 11:39 AM
    • Edited by bwhobby Tuesday, October 11, 2011 11:43 AM
    Tuesday, October 11, 2011 11:37 AM