locked
The 'OraOLEDB.Oracle.1' provider is not registered on the local machine RRS feed

  • Question

  • User-1607406849 posted

    My web site that connects to the Oracle database works fine with windows 2000 32 bit os and other 32 bit pcs. When I deploy it to a windows 2008 server 64bit server with IIS7 I get the following error

    The 'OraOLEDB.Oracle.1' provider is not registered on the local machine.  

    I gave every user under the sun permission to the oracle folder, still I get the same error.

    Could any one help please. Any help is greatly appreciated.

    Friday, September 16, 2011 8:06 PM

Answers

  • User-1607406849 posted

    Thanks Lannie. I think the first item you meniotned (explicitly compile the application as 32-bit) worked for me. I found the following :

    Applications connecting to an Oracle database server should run in an Application Pool configured with ‘Enable 32-Bit Applications’ = True.  This requires Oracle 32-bit drivers to be installed on the running system.  Use the IIS Manger to verify your application’s Application Pool.

    In the Connections pane, select your application:

    Click ‘Advanced Settings’ and verify the application pool used by your application

    Then select that application pool in the connection pane:

    Click ‘Advanced Settings’ and be sure that ‘Enable 32-bit Applications’ is True.

    If any one is intereted, please see the full article at :

    xxx.ironspeed.com/Designer/6.2.2/WebHelp/Part_V/OraOLEDB_Oracle_provider_is_not_registered.htm

    Again thanks for your reply. Much appreciated.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 20, 2011 10:25 AM

All replies

  • User269602965 posted

    Explicitly compile the application as X86 (32-bit) instead of AUTO or X64.

    Install the 32-bit Oracle Client and ODP.NET in a NEW Oracle Home on the application server.

    ODP.NET installer has an option after your start the install to select CLIENT or DATABASE install, select CLIENT.

    Saturday, September 17, 2011 5:01 PM
  • User-1607406849 posted

    Thanks Lannie. I think the first item you meniotned (explicitly compile the application as 32-bit) worked for me. I found the following :

    Applications connecting to an Oracle database server should run in an Application Pool configured with ‘Enable 32-Bit Applications’ = True.  This requires Oracle 32-bit drivers to be installed on the running system.  Use the IIS Manger to verify your application’s Application Pool.

    In the Connections pane, select your application:

    Click ‘Advanced Settings’ and verify the application pool used by your application

    Then select that application pool in the connection pane:

    Click ‘Advanced Settings’ and be sure that ‘Enable 32-bit Applications’ is True.

    If any one is intereted, please see the full article at :

    xxx.ironspeed.com/Designer/6.2.2/WebHelp/Part_V/OraOLEDB_Oracle_provider_is_not_registered.htm

    Again thanks for your reply. Much appreciated.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 20, 2011 10:25 AM