none
After installation, all users log in with a temporary profile - RDS RRS feed

  • Question

  • I am installing FSLogix in our Azure Test Environment for an RDS implementation.  I have now done this twice, with new servers and following the documentation, which is IMHO somewhat lacking for RDS.

    Broker is Server 2019 DataCenter.

    RDSH Servers are same.

    File Server is 2016 DataCenter with P30 Disk for Container Location.

    Clean installs of Server, and FSLogix.

    Configured ONLY profiles with FSLogix Config Tool.  Settings are Enabled, VHDX and Profile Path.

    Using Test Users with no profile path in AD.

    When I log in the users, it creates the folder in the correct path, but on the remote desktop, it logs in with a temp profile.

    It now does this for ALL USERS logging into the server, whether it is a test user, or the domain admin logging in via mstsc /admin.

    Attempted to open a support case, but I have no SA, as it is Azure, and I have no plans on paying for support for a POC.

    Has anybody successfully implemented this is RDS?  If so, is there clean documentation somewhere?

    Has anybody run into this Temp Profile issue that can advise on a fix?

    Appreciate any assistance.

    James

    Wednesday, October 30, 2019 3:45 PM

All replies

  • James,

    We have this running on our RDSH Farm with a setup that sounds similar to yours. We have an RDSH gateway and broker (ours is on the same server) with around 17 RDSH servers that our users log on to. 



    We are doing this in our VMWare environment and not using Azure. The few things that I can point out (which you may have already checked) are:



    1. The only two registry settings that need to be enable for a basic setup is the Enabled setting has to be set to 1 and the VHD locations should point to your file share, \\server\path. (https://docs.microsoft.com/en-us/fslogix/configure-profile-container-tutorial)

    2. Make sure the Exclude and Include groups are configured correctly. I had the issue where I misspelled one of them on one of the servers and it took me a bit to figure out what was happening.

    3. Make sure in azure that you can connect to the file share. Since I don't have it working with Azure I'm not sure if you have any security settings enabled for file shares to work with only a specific network.

    4. Make sure you have the correct permissions for the software, server and user to create the files.(https://docs.microsoft.com/en-us/fslogix/fslogix-storage-config-ht)

    Thats all i can think of for now. 
    6.3.6
    Thursday, October 31, 2019 2:42 PM
  • Thanks Darth, 

    I am going to blow it all away and start from scratch.  I will pay more specific attention to the security of the folder.

    Appreciate the input, and will post my results.

    James

    Tuesday, November 5, 2019 11:13 PM
  • James,

    Happy to help.

    6.3.6
    Wednesday, November 6, 2019 1:54 AM