none
VHLK 2004 test stuck in waiting queue RRS feed

  • Question

  • I've installed the VHLK 2004 in a VM. I have Win 10 2004 on a client. HLK client software installed. My client is 'Ready' and in a machine pool on controller. When I select a test to run it sits in 'The test is in the waiting queue'. I have a VHLK 1903 VM set up and am able to run tests on a 1903 client.
    Thursday, August 6, 2020 7:51 PM

All replies

  • Make sure that the Controller and the Client can ping each other, you can also open HLK Manager and look under Explorer --> Job Monitor and see what is the hold up.

    These mostly due to Client going into Not Ready State or loss of communication between Controller and the Client.

    Also I would check that the HLK Communication Service on both the Controller and Client is started and running.


    Thanks!

    Friday, August 14, 2020 5:04 PM
  • They can both ping each other via ip and name. I can see the heartbeat increment every 10min. The client always stays in the ready state. The hlk service is running.

    I decided to try to put the VHLK on to another host and I'm able to run tests. The only difference is the host that can't run tests is Win10 1903 with VHLK 2004. Where the host that works is Win10 2004 with VHLK 2004. There must be something different in the hosts where the VM has issues communicating with the clients. If this is a known/recommended config maybe an update to the VHLK docs would clarify.

    Friday, August 14, 2020 5:12 PM