locked
RC or RTM? RRS feed

  • Question

  • User1358870704 posted

    Could you please tell me when can we expect RC or RTM?

    I've been testing real time logging about a month and it works perfectly for me. I occasionally see error message in the event log "The description for Event ID 0 from source IIS Advanced Logging Module cannot be found. "

    But I suspect that may be something to do with my code!

    Tuesday, September 29, 2009 12:54 AM

All replies

  • User-1292338562 posted

    Hi jjy2,

    The RTM version will be shipping shortly, within the next few weeks.

    Its hard to tell what you're running into, but it looks like the resource strings weren't registered correctly.  One thing you could try is to go into your 'Programs and Features' UI in the Control Panel, select the 'IIS Advanced Logging' option, and click on 'Repair'.  (Make sure your event viewer window is closed.) 

     Another thing you could try is to enable FREB to see if that gives you any additional information.  You could start here:  http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis-70/ .  There's also other help available for FREB if you do a search on Bing using the keywords:  failed request tracing .

    Please keep us updated with your status on resolving this issue.  thx...

     - bobby

    Wednesday, September 30, 2009 12:56 PM
  • User-1292338562 posted

    FYI...the rtw version has just been released.  At your convenience, please take a look and let us know any additional feedback you might have. 

     http://www.iis.net/extensions/AdvancedLogging

    Thanks...

     

    Monday, October 12, 2009 6:39 PM
  • User1358870704 posted

    Hi Bobby,

    Thanks for the update!

    I have setup "failed request log" for any errors since, but I havent' find any useful information that are related to those event logs yet  

    But if I find anything, I will post the information

    Thanks Bobby.

    Monday, October 12, 2009 6:55 PM
  • User1358870704 posted

    Hi Bobby,

    I suspect the error was this

    Failed to initialize performance counter \W3SVC_W3WP(_Total)\Requests / Sec. Data for this performance counter data will not be recorded until the counter is available. PdhCollectQueryData: 0x0X800007D5.

    I see this message after I installed RTM (maybe string table entry for this error was missing before)

    Tuesday, October 13, 2009 8:44 AM
  • User-1292338562 posted

    Yeah, the initial error you posted indicated that the event viewer resources didn't get properly registered.

     As for this perf counter, if you open perfmon, are you able to see data there?  Also, are you doing any impersonation at all in your application?

    Tuesday, October 13, 2009 2:11 PM
  • User1358870704 posted

    I could add & monitor "Request/Sec" counter of object "ASP.NET Apps v2.0.50727" in the perfmon, (is that the right counter?)

    I don't do any impersonation in my application and the site is using "Network Service" identity
    Sometimes it gives me a valid number for the field, but most of time it is nil.

    Wednesday, October 14, 2009 8:14 AM
  • User-1292338562 posted
    No. The correct counter would be "Requests / Sec" under object "W3SVC_W3WP" for instance "_Total". Also, to verify these counters, its best to apply some load to your web server by making a few requests. These are live values so if there are no requests coming in, the perfCounter would have no data to report. This might explain why it is 'nil'.
    Friday, October 16, 2009 4:33 PM
  • User1358870704 posted

    I tried the counter for the _Total instance and it looking good in the perfmon 

    While Internet explorer is running, I just pressed F5 key for 10+ seconds, and I could see the impact immediately. So I guess I don't really need to concern about that event log error message as it will keep write the log entry whenever the counter is not available? (it looks like rather a warning message )

    Whenever my machine boots up I see this error message and also periodically recorded (maybe when wswp is unloaded)?

    I think I am happy with this error message, but if you need any more information please let me know. I am currently testing real time logging with IIS 7.5 server on Windows 7 Ultimate. 

    Thank you for this great tool! I will soon install it in my web server as well.

     

    Friday, October 16, 2009 9:55 PM
  • User-1292338562 posted

    Yeah.  We're not actually doing anything special with PerfCounters.  We're merely querying for information and reporting back whatever gets returned.  The events you're seeing seem to be 'warnings', as you mention.

    Just to clarify, you were able to see actual values in your log files when your server was under load, correct?

    Monday, October 19, 2009 7:09 PM
  • User1358870704 posted

    Hi again,

    When the server was under load, I see the value in the log files ok.
    I was just curious when I found the error in the event log with Beta1

    Thank you.

     

    Monday, October 19, 2009 9:19 PM