none
Visual Studio hangs when creating an App Service.

    Question

  • Inside VS2015 trying to create a new project and hosting it in azure. Which brings up the 'Create App Service' dialog. At this point I cannot click on anything in the dialog or VS. I have to kill the process. I have attached image of the dialog to be clear. I also get the "Microsoft Visual Studio Is Busy" notification over and over again. No idea if it makes a difference but this a ASP.NET 5 web project.

    Regards,

    Nick Munday


    Thursday, February 4, 2016 9:52 PM

Answers

All replies

  • Hi Nick,

    Could you tell me what’s the version of your VS2015?

    I did a test in my side using VS2015 Community update1. And it works well in my side.

    Please check how much RAM do you have?  Some members encountered the same error and solved by  adding RAM.

    So first check your RAM and restart your computer and reopen your VS then try it again.

    Try running Visual Studio in Safe mode to Check whether some add-ins and extensions affect it (devenv /safemode)

    Also you could try to run the following commands then try it again :

    Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

    In addition. I suggest you’d better close the firewall and the anti-virus software or other third party processes then try it again.

    If above suggestions still no help. I suppose there is something wrong with your Visual Studio.

    In this case, I suggest you could repair your VS or install the VS2015 Update1 then try it again.

    Hope that could be helpful to you.

    Best Regards,

    Lake Xiao


    Saturday, February 6, 2016 1:00 AM
    Moderator
  • To fix this upgrade to Azure SDK 2.8.2

    https://azure.microsoft.com/en-us/downloads/

    Select VS 2015 under the .NET heading

    Tuesday, February 9, 2016 4:00 AM
  • Hi John,

    Have your issue been solved?

    If your issue was solved, please mark the reply which is helpful so that I could this case.

    Thanks for your understanding.

    Best Regards,

    Lake Xiao

    Tuesday, February 16, 2016 7:32 AM
    Moderator
  • Installing the latest Azure SDK (2.9 as it happens now) fixed the problem for me.
    Tuesday, July 26, 2016 10:56 PM
  • In Visual Studio 2015 Enterprise Edition, if you use the Extensions and Updates dialog, when you click the Update button, you get the following.  So, use Jon's link above instead.  (sheesh!!)

    I have to say, I've found Visual Studio 2015 to be plagued by problems that take serious time away from working productively.  Worst Visual Studio experience ever.  I notice Microsoft has followed the convention of skipping number "13" in versioning, as with other products.  Because... bad luck?  I really hope that for version 15, the company will rely more on testing and quality control and less on superstition.

    Tuesday, September 13, 2016 3:07 PM