locked
SSDT Deploy Error RRS feed

  • Question

  • Hi 

    I'm new to using SSDT and decided to play around with it.

    I'm currently getting a deployment error and was hoping someone would have a solution:

    SQL72014: .Net SqlClient Data Provider: Msg 9982, Level 16, State 100, Line 1 Cannot use full-text search in user instance.

    I'm assuming this something to do with full-text search on the localdb being used, but not sure how to enable it.

    Anyone have any ideas on what I could do?

    Thanks

    R

    Saturday, May 25, 2013 11:20 AM

Answers

  • Unfortunately LocalDB does not support full-text search feature. In order to test this you would need to test against a full version of SQL Server. I believe there is a SQL Server Developer Edition available for this reason - it lets you install a server on your development machine for test purposes. Be sure to turn on the full text index feature of this server.

    Once you have that installed, you can change your F5 debug deployment target in the Project properties. Right-click on the project, choose "Properties" and navigate to the Debug section. You will see the "Target Connection String" with the Data Source pointing to "(localdb)\Projects". Edit this to point to your local server and now your debug deployments will go to that server. Good luck!

    Kevin

    Tuesday, May 28, 2013 8:34 PM