none
Failed job execution: Could not load file or assembly __ScopeCodeGenEngine_

    Question

  • Hello all, 

    I'm hitting a wall debugging a custom extractor I wrote in a C# code-behind. The extractor is intended to parse emails contained in plain text files. It works when tested locally against 10 sample files and it's worked when submitted to ADLA against 15 sample files and 1000 sample files. But, when I execute it against the entire set of 3800+ files I get the following error in 201 vertices before the job quits. 

    

    Every method in my custom extractor is wrapped in a try/catch to report the location of the error, so I'm reasonably confident it's not entering my code and failing. 
     
    I've tried local debugging following this blog post: https://docs.microsoft.com/en-us/azure/data-lake-analytics/data-lake-analytics-debug-u-sql-jobs#download-failed-vertex-to-local-machine Each time I follow the process, I get results similar to the error from ADLA. 

    Any ideas? Have I hit some bug or unpublished (and horribly reported) limit in ALDA?

    Monday, December 11, 2017 8:40 PM

All replies

  • Hi Levi, Matt from the ADLA team.  I just want to let you know that I'm looking into your issue now.  If possible, could you send me the job link and your custom extractor (mabasile <at> microsoft.com) so I can take a look at it and better debug what's going on? Thanks!
    Tuesday, December 12, 2017 9:38 PM