none
DataGridView display gibberish for all characters

    Question

  • Using Visual Studio 2012 Visual Basic.  Creating an complex application and just added a form to manage my Access DataBase (2007 version).  I am using a workstation with Windows 10.  Accessing the database and getting the data into a DataSet works just fine.  I have programatically accessed the DataSet to verify the correctness of the data.  When assigned to DataGridView.DataSource the correct number of rows and columns are displayed; however, all of the data is presented as single-character rectangles and other single-character graphic-characters.  The gibberish characters appear to be the correct width.  It almost appears as if there is a character mapping issue.


    If I attempt to programatically add some rows of string data to the DataSet, they are also displayed as gibberish.


    Any suggestions?


    Thanks.

    Tuesday, March 28, 2017 8:29 PM

All replies

  • Any suggestions?


    Thanks.

    Hi

    Yes! Maybe posting some code would help.


    Regards Les, Livingston, Scotland

    Tuesday, March 28, 2017 8:41 PM
  • Hello,

    Is the ms-access database using a different language set from the location is resides as ms-access uses the culture to where it physically resides.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    Tuesday, March 28, 2017 10:28 PM
    Moderator