none
Azure Storage Emulator Error

    Question

  • Hi

    I am not able to run my Application on my machine. It gives me the below error

    "Microsoft Azure Tools: Failed to initialize Microsoft Azure storage emulator. The storage emulator needs to be initialized. Please run the 'init' command. An unknown error has occurred."

    I tired to initiate the storage using command prompt "WAStorageEmulator.exe init", it also fired the same error like "No SQL Instance was found".

    Also i tried to stop, delete and create the local db. Nothing worked

    Got the same error again.

    Thnaks

    Mohammed

    Wednesday, April 29, 2015 5:48 PM

Answers

  • Hi Mohammed,

    When you say my machine, are you running this app in a local machine and not an Azure VM?
    Do you have an SQL server installed in your machine?
    You could try referring the following link and check if it helps:
    http://www.nimbo.com/blog/error-failed-to-initialize-windows-azure-storage-emulator/

    Regards,
    Malar.

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Thursday, April 30, 2015 1:57 PM