none
.net framework 4.0 roll backs RRS feed

  • Question

  • Hello,

    I have this issue where .net framework 4.0 keeps rolling back it's installation. For the past few days, I've been searching and troubleshooting various methods to this problem which includes:

    • Running as administrator
    • Running the program in a secondary administrator account
    • Using the dotneffx_cleanup_tool
    • Cleaning the temp folder after each installation attempt
    • Used a microsoft fix it program
    • Used the windows update
    • Checked and changed permissions to the registry
    • Tried the full setup and client setups
    • Removed, restarted, and attempted re-install of  .net framework 4.0
    • Attempted to install other versions of .net framework such as 3.5 but didn't work
    • Checked my windows update history to see that majority of the failed updates even in the past few months are .net framework 4.0 updates
    • Restored to an earlier Windows Restore point

    The thing is, it has only been a few days ago that my computer has been working flawlessly for months. My programs that utilizes .net framework 4.0 has all worked fine. After that, I don't know what triggered it, but my computer just doesn't accept the idea of .net framework in its system again. I've scurried as much topics as I can related to troubleshooting this problem, and I'm not sure where else to look. 

    Here's my log, I hope more people can make more sense with this. 

    http://sdrv.ms/17tNcVQ

    Saturday, June 29, 2013 11:33 PM

Answers

All replies

  • From your log:

    "Could not write value RuntimeVersion to key \Software\Classes\CLSID\{1B979846-AAEB-314B-8E63-D44EF1CB9EFC}\InprocServer32\4.0.0.0.   Verify that you have sufficient access to that key"

    You have a registry permissions issue. Try to gain ownership of the key in question with an administrator account, then retry the install.

    Sunday, June 30, 2013 2:45 PM
  • The weird thing is, I've applied full control permissions to both System and Administrator on 4.0.0.0, InprocServer32, and all parent servers above that as a temporary measure to get it to work. At this point, if it's asking me about sufficient access, I've already given full control access to all folders leading up to 4.0.0.0. The installation still rolls back. Looking at a newly created log mentions that the same error persists. 
    Sunday, June 30, 2013 5:55 PM
  • Hi,

    From the log, I find the error:

    [6/29/2013, 17:16:31] Error 0x80070424: Failed to open the current cluster

    To solve this error, please try the solution below:

    http://windows.microsoft.com/en-ID/windows7/Windows-Update-error-80070424

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, July 2, 2013 8:30 AM
    Moderator