none
InfoPath 2013 form in SharePoint 2013 list missing buttons RRS feed

  • Question

  • If this is a stupid question please forgive me but i am not an expert in this stuff and i am trying to learn it.  Here is my question/issue.

    I create a form in infopath 2013.  The form has multiple views (pages) and i have buttons at the bottom of each view (page) to advance to the next page or return to the previous page.  Each view (page) has a distinct set of questions and i have designed my views (pages) this way as a logical grouping of similar questions.

    I can publish the form to my SharePoint (2013) site list.  I can then browse to my SharePoint list and 'add new item' - my form opens and i can enter data and use the buttons at the bottom of each page to advance to the next page (or return to the previous page).  Once i have completed entry of my data I click save and the form is closed and i can see my newly added transaction displayed in my list.  All is fine.

    If, however, I click on that entry in the list - so i can review the data entered - the first page (first view) displays but my navigation buttons are missing. I cannot advance to the next page(s) to review the rest of the data entered (three pages in total - in InfoPath i created three views and used the buttons to move between views). If, however, i click edit then the form is opened and i see the buttons to move between pages.

    What I want to know is how can i have the buttons be displayed while in view mode and not edit mode when i want to review the data for that entry in the list.

    As i stated, i am not an expert in this so any response needs to be explained in easy terms :)

    Please help!

    Steve

    Thursday, December 6, 2012 2:50 PM

Answers

  • Figured it out.  Need to use Picture Buttons and not regular buttons

    now i just have to figure out how to put text in a picture button.....

    • Marked as answer by Emir Liu Thursday, December 13, 2012 11:04 AM
    Thursday, December 6, 2012 10:02 PM

All replies

  • Figured it out.  Need to use Picture Buttons and not regular buttons

    now i just have to figure out how to put text in a picture button.....

    • Marked as answer by Emir Liu Thursday, December 13, 2012 11:04 AM
    Thursday, December 6, 2012 10:02 PM
  • When using picture buttons, head to the picture button properties and deselect the option that says 'Hide picture button in read-only views'.
    Tuesday, April 1, 2014 9:37 AM