locked
SSRS Report not using passed parameters; Uses embedded parameters instead RRS feed

  • Question

  • I have a report that takes a start date and end date as parameters. In the data tab of Business Intelligence Studio (visual studio), I have the following:

    declare @start datetime
    declare @end datetime
    
    set @start = '2011-04-06T12:00:00'
    set @end = '2013-04-06T12:00:00'
    
    EXEC rpt_ExpiredQuickLook @start, @end

    When I run the report on the report server and pass it different date parameters (let's say 2013 to 2014), I still get the ones I had in visual studio. Is there a setting in the report somewhere to use the passed parameters over the ones embedded? On the report server, I have the Prompt User checkbox checked under the report settings.

    I have other reports that I created in the past that don't have this problem, so I'm super confused.

    EDIT: I should mention that I'm using Visual Studio 2005 to create the reports and deploying on SQL Server 2012 reports server
    • Edited by Bobidybob Tuesday, August 19, 2014 6:27 PM
    Tuesday, August 19, 2014 3:27 PM

Answers

  • I got this figured out. Even though SQL Server 2012 is supposed to upgrade the report when you upload old versions of reports, SSRS 2005 report files that use parameters will simply not work on a SQL Server 2012 server. They just handle parameters differently. The solution is to download the new version of Business Intelligence Studio and convert the reports manually and reconfigure the parameters for them. This should fix the parameter problem.
    • Marked as answer by Bobidybob Wednesday, August 20, 2014 4:07 PM
    Wednesday, August 20, 2014 4:07 PM