locked
Image is not showing in Crystal Report Viewer rendering in ASP.NET 4.5 webform RRS feed

  • Question

  • User-34860367 posted

    Hi,

    I am developing ASP.NET Web Application using VS Pro 2013 tool and of CRforVS_13_0_13 version. There is an issue that the images won't show in Crystal Report Viewer in ASP.NET web form page either IE or google chrome browser. I can insert the images into Crystal Report designer and export them with Crystal Report built-in function in PDF.  I search several answer that relate to web.config but could not resolve the problem. Here is my web.config that relate to image as following: 

    <httpHandlers>
    <add path="CrystalImageHandler.aspx" verb="GET" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" />
    <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91"
    validate="false" />
    </httpHandlers>
    </system.web>
    <system.webServer>
    <modules>
    <remove name="FormsAuthentication" />
    </modules>
    <handlers>
    <add name="CrystalImageHandler.aspx_GET" verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" preCondition="integratedMode" />
    <add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
    </handlers>
    <validation validateIntegratedModeConfiguration="false" />

    I believe the web.config automated adding above codes when we added the images on Crystal Report designer. Anyone found the solution how to work around, please help. Thanks in advance.

    Friday, May 15, 2015 9:21 AM

Answers

  • User-34860367 posted

    I found the solution from SAP forum. Just change settings.AutoRedirectMode = RedirectMode.Permanent to settings.AutoRedirectMode = RedirectMode.Off in RouteConfig.cs

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 31, 2015 12:57 AM