locked
WebView control navigation fails for certain url on intranet?

    Question

  • I've developed a windows 8 store app which is side loaded onto a win8.1 pc and ran in kiosk mode.

    The app lets users tap on a menu item to display an associated url in the webview control.

    All is working fine apart from 1 intranet url. The navigation completed event return IsSuccess = false with a error code 14, cannot connect.

    This is instant, it does not seem to try and even find the url.

    The only difference between this url and others used, is it contains a sub domain, example https://hr.company.com where company.com is the public internet domain and the sub domain bit is hr which is only available on the intranet, which the pc has access to.

    As a test I tried https://mail.company.com and this works because the sub domain mail is available on the internet (not just the intranet)??

    If I put the url https://hr.company.com into IE on the same pc it works fine, but in the webview it gives cannot connect (err 14).

    Please help, client wont pay for app till it's working :(

    Wednesday, April 16, 2014 2:09 PM

Answers

All replies

  • Do you have the privateNetworkClientServer capability? See How to set network capabilities

    Can you get to the same site from IE?

    --Rob

    • Marked as answer by geoLog UK Thursday, July 10, 2014 5:28 PM
    Wednesday, April 16, 2014 2:51 PM
    Owner
  • Hi Rob

    It was not checked but is now, I cant test it until the client site is open tomorrow, so I'll update the post then.

    I can get to it using IE, that's whats puzzling me? Maybe privateNetworkClientServer capability will fix it, it does load many other intranet pages correctly, just this particular one, it's an oracle ebusiness hr system?

    Thanks

    Jason

    Wednesday, April 16, 2014 5:04 PM
  • Hi Rob,

        I am also facing similar issue while trying to navigate to url "http://go.microsoft.com/?linkid=9843570". This url works fine when attempted using Internet Explorer app but fails in my app using webview control.
        But when I ran fiddler and added its(fiddler's) certificate to Trusted root, the WebView in my App successfully navigated to the mentioned url. Otherwise when the fiddler is not running, I get same error i.e. "CannotConnect" in the navigationCompletedhandler of the control.
        I even checked by setting various capabilities in AppManifest like "Enterprise Authentication", "Internet", "Internet(Client & Server)" but didn't get any resolution.
        Here is the queue of navigation done by the webview control while fetching the url

    1.https://go.microsoft.com/?linkid=9843570
    2. http://www.microsoft.com/itacademy/members
    3. https://www.microsoft.com/en-us/itacademy/members
    4. https://www.microsoft.com/en-us/itacademy/members/
    5. https://corp.sts.microsoft.com/adfs/ls/?wa=wsignin1.0&wtrealm=https%3a%2f%2fwww.microsoft.com......
    6. Navigation to https://go.microsoft.com/?linkid=9843570 fails with error code CannotConnect

    When I set the "Private Networks(Client & Server)" along with "Internet(Client & Server)" capability I get WebErrorStatus as "Unknown" instead of "CannotConnect".
    Please help as the app is almost in the deployment stage.

    --Swapnil

    Thursday, April 17, 2014 11:39 AM