none
Calling a framework 4.0 dll from framework 3.5 binary RRS feed

  • Question

  • Hi,

    My app is in dll which is called from a binary created by a different group. If the binary is still built using .NET framework 3.5, then can it load a dll built on framework 4.0?

     

    -Thanks,

     

    -Brajesh

    Sunday, November 14, 2010 4:04 AM

Answers

  • Hi Brajesh,

    You can easily verify this yourself by creating two projects, one 3.5 and one 4.0 and then reference them. It will not work.

    It has also been asked before, have a look here

    Kind regards,
    Tom de Koning


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".
    • Proposed as answer by Tom de Koning Sunday, November 14, 2010 10:01 AM
    • Edited by Tom de Koning Sunday, November 14, 2010 10:04 AM Provided link to answered question
    • Marked as answer by brajeshkumar69 Monday, November 15, 2010 7:10 AM
    Sunday, November 14, 2010 10:01 AM
  • Well I found that if I could put the requiredrunTime flag in app.config file to target framework 4.0, then it works.

    My blog here http://brajeshseattle.blogspot.com/  explains this in details.

     

    -Brajesh

    • Marked as answer by eryang Tuesday, December 7, 2010 8:36 AM
    Friday, November 26, 2010 3:30 AM

All replies

  • Hi Brajesh,

    You can easily verify this yourself by creating two projects, one 3.5 and one 4.0 and then reference them. It will not work.

    It has also been asked before, have a look here

    Kind regards,
    Tom de Koning


    If a post answers your question, please click "Mark As Answer" on that post and "Mark as Helpful".
    • Proposed as answer by Tom de Koning Sunday, November 14, 2010 10:01 AM
    • Edited by Tom de Koning Sunday, November 14, 2010 10:04 AM Provided link to answered question
    • Marked as answer by brajeshkumar69 Monday, November 15, 2010 7:10 AM
    Sunday, November 14, 2010 10:01 AM
  • Well I found that if I could put the requiredrunTime flag in app.config file to target framework 4.0, then it works.

    My blog here http://brajeshseattle.blogspot.com/  explains this in details.

     

    -Brajesh

    • Marked as answer by eryang Tuesday, December 7, 2010 8:36 AM
    Friday, November 26, 2010 3:30 AM