none
Health Care 277 Claim Status Notification [ 005010X214 ] RRS feed

  • Question

  • Hello,

    Where can I get a copy of the .xsd   for a  277_A ?  I keep getting an error in the EDI disassembler- 

    BizTalk 2010 with  CU-6  installed.

    Microsoft BizTalk Server Administration
    Microsoft Corporation
    Version: 3.9.469.0

    Running on  -

    Windows Server 2008 R2  Standard

    Management Console  3.0

    Version 6.1  ( Build 7601: SP1 ) 

    ------------------   Begin error message  ---------------------------------------

         Error encountered during parsing. The X12 transaction set with id '' contained in functional group with id '516392363', in interchange with id '516392363', with sender id 'CLAIMSCH       ', receiver id 'PV             ' is being suspended with following errors:
    Error: 1 (Miscellaneous error)
    517: Message Type 277_A is not allowed as part of the Agreement.

    Error: 2 (Miscellaneous error)
    6: Finding the document specification by message type "http://schemas.microsoft.com/BizTalk/EDI/X12/2006#X12_00501_277_A" failed. Verify the schema deployed properly. 

    .
     The sequence number of the suspended message is 1.

    ------   End of error message  -----------------


    Wednesday, July 31, 2013 3:21 PM

Answers

  • On the Validation tab of the Agreement, you can check "Allow leading and trailing zeros and spaces"
    • Marked as answer by basscleff Friday, August 2, 2013 1:22 PM
    Thursday, August 1, 2013 9:07 PM
  • Was there a problem with the previous answer?  It's been unmarked as answer.

    You don't want to change that data type.  In fact X12_N0 would be wrong.  QTY02 is defined as R (real) which can be a singed decimal number.

    X12_N0 is technically an Integer format with 0 implied decimal places.  That effectively an Integer.

    Allowing the leading zeros is what you want to do.

    • Marked as answer by basscleff Friday, August 2, 2013 1:35 PM
    Thursday, August 1, 2013 9:41 PM

All replies

  • The 277_A was shipped with one of the CU's but there is a bug in the CU installer such that the MicrosoftXsdTemplates.exe zip file was not copied to the install folder.

    What you can do is open the CU .msi will something like WinRAR or WinZip and extract the templates manually.

    I don't know if it's in CU6 but I'm 95% sure it is in CU5.

    The file is 277_A so don't get confused with the 277 in the HIPAA folder.

    • Marked as answer by basscleff Thursday, August 1, 2013 12:58 PM
    • Unmarked as answer by basscleff Thursday, August 1, 2013 1:14 PM
    Wednesday, July 31, 2013 3:42 PM
  • I will try extracting the  HIPAA  xsd's  manually.   

    Please note the folder name is  277_CA,  in xsd templates "zip" file located in CU 5.

    I may have another question later,  but current question has Microsoft came out with a fix for CU installer?

    Reason is of course this has taken a few days to determine the problem.   As best as I can determine there is nothing on the web regarding a bug in the CU installer.

    To boatseller-  Your reply appreciated!

    George




    • Edited by basscleff Thursday, August 1, 2013 1:53 PM
    Thursday, August 1, 2013 1:03 PM
  • There are two  *folders* in CU5 for the xsd Templates, one named  277_CA  the other the  999 .

    Next question is where to place the two folders, or do I place the schemas contained in the folder in the current location ?  

    btw,  There are subfolders under ../276-277   one named  'multiple'  the other is 'single'.   Which adds some unclarity toward a good manual install.

    The actual location on the server is:

    C:\Program Files (x86)\Microsoft BizTalk Server 2010\XSD_Schema\EDI\HIPAA\5010\276-277 .   should folder  '277_CA'  reside on same 'level' as  276-277 ?

    bassclef   ( George ) 



    • Edited by basscleff Thursday, August 1, 2013 1:54 PM
    Thursday, August 1, 2013 1:25 PM
  • This or this article might help.


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.


    • Edited by SAAkhlaq Thursday, August 1, 2013 1:57 PM
    Thursday, August 1, 2013 1:47 PM
  • Don't worry about the zip folders or anything in the XSD_Schema folder.

    You have to extract the 277_A and add it to your project. 

    You can copy it over to XSD_Schema, but nothing ever looks there.  All EDI schemas have to be deployed in a project/assembly to be used.

    There is no fix I'm aware of for the installer.  I reported this like forever ago but never looked to see if it was fixed.

    • Marked as answer by basscleff Thursday, August 1, 2013 8:28 PM
    • Unmarked as answer by basscleff Thursday, August 1, 2013 8:50 PM
    Thursday, August 1, 2013 2:41 PM
  • that cleared up the original issue.

    However,   I tested the schema with several data files.  There is an issue with TS277_2200B_Loop,  QTY02_TotalAcceptedQuantity.

    The data being sent in QTY02 is :  000000000292.    

    The element does not like the leading zeros.   I deleted the leading zeros and the schema will validate the data as fine.

    Any idea on how to correct the schema to allow   leading zeros ?

    [ btw - the schema came from CU-06,  July  2013 ]

    George

    Thursday, August 1, 2013 8:34 PM
  • On the Validation tab of the Agreement, you can check "Allow leading and trailing zeros and spaces"
    • Marked as answer by basscleff Friday, August 2, 2013 1:22 PM
    Thursday, August 1, 2013 9:07 PM
  • OK.  I will try the agreement.  

    There seems to be an alternate.   For the element in question,  I checked out the Data Type properties,  .

    Three is a drop down list and low and behold  an option for " X12_N0 ( Simple Type ) ".  Which the EDI format  'N0' does make sense.   I set it. and tested with the file and it worked.

    I will back out he adjustment and also try the option on the agreement.

    ahhh....  is there a way to remove the setting back to a blank ???  It seems  'stuck'  to the setting.

    George

    Thursday, August 1, 2013 9:21 PM
  • Was there a problem with the previous answer?  It's been unmarked as answer.

    You don't want to change that data type.  In fact X12_N0 would be wrong.  QTY02 is defined as R (real) which can be a singed decimal number.

    X12_N0 is technically an Integer format with 0 implied decimal places.  That effectively an Integer.

    Allowing the leading zeros is what you want to do.

    • Marked as answer by basscleff Friday, August 2, 2013 1:35 PM
    Thursday, August 1, 2013 9:41 PM
  • yep,    When I saw that in the schema properties,  under "Data type"  I felt it was an option.   It is not so unusual  [  unfortunate- yes!! ]  that trading partners do *not*  honor the document standard  as published and go their own way with formats.   

    Right now I am wondering with an "R"  format  why the actual value  '000000000292'  is failing at all.   In my experience,  R means  leave as-is,  even if there is no "." .

    (  btw,  I went back and marked the response as an answer,  .... and voted    :-)  .   )

    Thanks for your input    !

    basscleff

    Friday, August 2, 2013 1:34 PM
  • Ok, just wanted to make sure I didn't steer you in the wrong direction.

    Yes, for R, the decimal and - (minus sigh) are optional.

    What exactly is failing?  The leading 0's should still be parsable as a Double.

    Saturday, August 3, 2013 3:16 AM