locked
witness not working RRS feed

  • Question

  • We are trying to set up database mirroring. The mirroring works for the principal and mirrored databases (set up via Management Studio), but when we try to set up the witness database, we are getting the error message “The ALTER DATABASE command could not be sent to the remote server instance 'TCP://… (Error: 1456)”.

    The same occurs if I try to do “ALTER DATABASE xxx SET WITNESS =” in TSQL. We are using the Standard edition for all three. We have tried using several different servers for the witness. All same user, same domain. Any suggestions?

    Thanks.

    Tuesday, October 24, 2006 5:37 PM

All replies

  • Hi,

    Could you please doublecheck the following:

      - that in the set witness statement you are specifying the correct fully qualified network name and port for the witness machine and

      - the mirroring endpoint you created on the witness instance was created for WITNESS or ALL, i.e.:

    CREATE ENDPOINT ... FOR DATABASE_MIRRORING (ROLE = WITNESS | ALL);

    - Kaloian.

     

    Wednesday, October 25, 2006 5:00 AM
  • Thanks. We are using management studio, so are not entering the sql statements but  "SELECT role_desc FROM sys.database_mirroring_endpoints" returns "witness".  It looks like one server is establishing a connection with the witness, but the other one is not.

     

    Wednesday, October 25, 2006 4:20 PM
  • What type of authentication are you using? Do all 3 servers involved have the appropriate permissions to access the other 2?  Sounds like they do not.

    If you are using certificates like I am, then make sure each of the three servers has the certificates from the other two and the appropriate logins and permissions granted to them.

    Wednesday, October 25, 2006 7:38 PM
  • Thanks. All the servers have the same domain and are using the same admin account so we are not using certificates. When setting up the mirror, we have tried both windows authentication and SQL Server authentication.

    Thursday, October 26, 2006 1:08 PM
  • We have tried switching the roles of the servers and it looks like the witness will only connect to one server at a time.
    Friday, October 27, 2006 5:18 PM
  • Do you get the solution at the end. I have the same problem. Please let me know.

     

    Thursday, March 22, 2007 8:23 AM