locked
Silverlight 2110 InitializeError - what is meaning of this error and how to solve this error? RRS feed

  • Question

  • Hello,

    I have Silverlight project which will build and run on IE 11 is Ok.  In this project have many sub-project, and almost platform target are Any Cpu.  With this platform target is Any Cpu, and running on IE browser is no trouble.  But now, I received request to change all target platform to x86. When I changed all target platform to x86 cpu and build process by visual studio is no errors displayed. But when I run on IE browser, it happen a message error like that:

    "

    Line: xx

    Error: Unhandled Error in Silverlight Application
    Code: 2110   
    Category: InitializeError      
    Message: 2110 An error has occurred.  

    "

     Now, my project is running on window 7 64 bit.  I tried to find the way to solve this, but on the many information that i found has no correct answer for this problem.

    Beside, I tried to use MSbuild to rebuild this project and run on IE but I got same error.

    So, Anyone have any suggest to me how to go about troubleshooting it? How to running on IE is ok with x86 cpu target form?

    Thank you!

    Wednesday, July 19, 2017 3:55 AM

All replies

  • Hi friend,

    Thanks for your post.

    Based on your description, it could the compatibility issue between Silverlight project with IE, as you mentioned your system is windows 7 64 bit, but you want to set the project’s target platform to x86 mode. Then you may need also set the IE as 32 bit to run it.

    We can change the program windows uses by default to open with different file extensions. The below steps could help to resolve similar issue. Please try it and check.

    On window 7:

    a. Click on Start and go to Default Programs.

    b. Click on Associate a file type or protocol always open in a specific program.

    c. Browse to all the extensions where internet explorer is set as default and then click on change.

    d. Now Click on browse and then go to location C:\Program Files (x86)\Internet Explorer\iexplore.exe and select it.

    e. Click Ok and then Close.

    f. Click Save.

     

     

    Hope it helps.

      

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Wednesday, July 19, 2017 9:49 AM
    Wednesday, July 19, 2017 9:49 AM
  • Thank you for your advise.

    I did as your recommend . But I still not yet solve this issue. The error message still display when I run website on IE. 

    Do you have any different ideal for this issue?

    BR,

    Khanh

    Thursday, July 20, 2017 6:33 AM
  • Hi Khanh,

    Thanks for your response.

    Please try to open the IIS Manager and navigate to the application pool that the application should run in. Select the application pool and select “Advance Settings…”. In the Advanced Settings dialog set the “Enable 32-Bit Applications” to true.

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Thursday, July 20, 2017 8:35 AM
    Thursday, July 20, 2017 8:34 AM