locked
Why are parameters not getting passed when I call a Web Service from JQuery Post Call in Custom Action Button? RRS feed

  • Question

  • Hi,

    IE9 and Sharepoint Online

    Calling the Web Method:

     [WebService(Namespace = "<a href="https:///">https://<service site>/")]
        [WebServiceBinding(ConformsTo = WsiProfiles.BasicProfile1_1)]
        [System.ComponentModel.ToolboxItem(false)]
        // To allow this Web Service to be called from script, using ASP.NET AJAX, uncomment the following line.
        [System.Web.Script.Services.ScriptService]
        public class MISServices : System.Web.Services.WebService
        {

            private string errMessage;

            [WebMethod]
            public void HTMLtoPDFSharepointListAttach(string HTML, string destSite, string fileName, string listName, string itemID, string authType)
            {

             ........................................

    From a Custom Action Button with call code

     try
     {
              
        $.ajax({
                    url: wsURL,
                    type: 'POST',
                    dataType: 'xml',
                    data: soapEnv,
        error: errorResult,
                    complete: processResult,
                    contentType: 'text/xml; charset=utf-8'
                }); 
     }
     catch(err)
     {
     alert('Failed to run ajax call: ' + err.message);
     }
     }

    Parameters are passed fine if the Sharepoint site is a http:// site. What security settings on IE9 could be stopping this?

    Thanks.

    John. 

    Tuesday, July 3, 2012 8:33 AM

Answers

All replies