none
[SOLVED] .Net Framework 3.5 won't install RRS feed

  • Question

  • I am running windows xp sp3

    I downloaded .Net Framework 3.5 from microsoft's download site. I've tried installing it about 30 times this week.

    Here is the uploaded error log "vslogs.cab"

    http://www.mediafire.com/?zjynhn0j5yn

    thank you
    • Changed type Figo Fei Monday, November 3, 2008 3:52 AM to comment
    • Changed type Figo Fei Tuesday, November 4, 2008 4:15 AM back to Q
    • Changed type Figo Fei Tuesday, November 4, 2008 4:15 AM back to Q
    • Edited by evan humphries Tuesday, November 4, 2008 4:37 AM
    Monday, October 27, 2008 5:00 AM

Answers

  • Solved it.

       1.  Re-register msxml3.dll by running regsvr32 msxml3.dll
      
    2. Re-install MSXML3 by downloading and installing the package from

    http://www.microsoft.com/downloads/details.aspx?familyid=28494391-052b-42ff-9674-f752bdca9582

       3. Then I turned "windows installer" under the services from manual to automatic.

    Somewhere in there did the magic.
    • Marked as answer by Figo Fei Tuesday, November 4, 2008 4:45 AM
    Tuesday, November 4, 2008 4:35 AM

All replies

  • Sorry I cannot open the link, could you please upload again using skydrive.live.com?

    Thanks.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    Wednesday, October 29, 2008 4:15 AM
  • Here is a skydrive link

    http://cid-0fc3574c705655d8.skydrive.live.com/self.aspx/Public/vslogs.cab

    PS. The mediafire link works. Not sure why you are having trouble.

    thanks again for your time fixing the error
    Monday, November 3, 2008 9:34 PM
  • The problem happened when it try installing WCF component:
    [10/26/08,21:00:48] Windows Communication Foundation: [2] Error: Installation failed for component Windows Communication Foundation. MSI returned error code 1603

    This may need to check out the event log launched by "eventvwr" in command prompt for detail information.

    Meanwhile, make sure that the installer is downloaded from the official website, and I've seen another case that ended with the registry permission issue, the potential solution is 
    Start > Run > open "regedit", navaigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog\Security\ServiceModel 3.0.0.0 and assign the permission to the user installing the .NET Framework.

    Thanks.

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. http://forums.msdn.microsoft.com/en-US/vssetup/thread/60424309-bd78-4ca2-b618-03c4a16123b6
    • Edited by Figo Fei Tuesday, November 4, 2008 4:14 AM typo
    Tuesday, November 4, 2008 4:13 AM
  • Solved it.

       1.  Re-register msxml3.dll by running regsvr32 msxml3.dll
      
    2. Re-install MSXML3 by downloading and installing the package from

    http://www.microsoft.com/downloads/details.aspx?familyid=28494391-052b-42ff-9674-f752bdca9582

       3. Then I turned "windows installer" under the services from manual to automatic.

    Somewhere in there did the magic.
    • Marked as answer by Figo Fei Tuesday, November 4, 2008 4:45 AM
    Tuesday, November 4, 2008 4:35 AM