none
Missing descriptions of methods and classes in visual studio

    Question

  • first of all sorry for my English. A few days ago I updated my VS 2015 community. After that there ware one problem: Missing descriptions of methods and classes in visual studio. Ill used russian VS, and I prefare to read description on russian language. What can i do in VS or at Windows that would return the description. Thank you!
    Friday, April 29, 2016 7:33 AM

All replies

  • I think the description is actually part of the .NET Runtime/dll's, not Visual Studio. Intellisense is meerly reading it out for you.

    It could be your installation of the .NET Framework is slightly broken.
    It could also be that Intellisense is running into some issue retrieving them for you.

    Friday, April 29, 2016 12:04 PM
  • Now I have translated my projects to .Net Framework 4.6 (old version is 4.5.1) mb i must to reinstal this framefork (4.5.1?)
    Friday, April 29, 2016 3:00 PM
  • Hi Simply god,

    Based on your description, your case more related to VS issue, I will help move your case to VS general forum for better support.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 03, 2016 9:47 AM
  • Hallo, okay
    Tuesday, May 03, 2016 4:49 PM
  • Hi Simply god,

    Could you please tell me what's the version of your VS2015 Community? Update1 or Update2?

    I did a test in my side using VS2015 Update2 and it works well for me. Please create a new project.

    Add "///" before your method. Then it will generate the descriptions automationly.

    Also you can select the DateTime then press "F12", it will jump to this page. Now you can see the descrptions of these methods.

    If the behavior in your side is not same to mine and you can't see the descriptions. I suppose some settings were changed. Please restore the setting of your Visual Studio then try it agian.(Tools->Import and Export Settings->Reset all Settings)

    Also try running Visual Studio in Safe mode to Check whether some add-ins and extensions affect it(devenv /safemode).

    If above suggestions still no help, I think something is wrong with your Visual Studio. Try to repiar your VS or install the VS2015 Update 2. The latest update of VS2015.

    If I misunderstood your issue, please feel free to let me know.

    Best Regards,

    Lake Xiao

    Wednesday, May 04, 2016 2:09 AM
    Moderator