locked
FastDev Issues - Driving me crazy RRS feed

  • Question

  • User10473 posted

    Hi guys,

    The last couple of days iv been getting the message 'FastDev directory creation failed' 'Deployment failed because the FastDev assembly directory could not be created.' I do not have 'Use fast Development' ticked from within Visual Studio, so I have no idea why this is appearing all of a sudden. Its worth noting that 9 out of 10 times this appears when debugging to my HTC One X, and has only happend within the last two days.

    Can anybody shed some light on this? Its getting to the point where i spend most of my time trying to get the thing to debug, rather than actually coding.

    Thanks

    Friday, May 17, 2013 8:58 AM

All replies

  • User10473 posted

    Can anybody help? Still have this problem and im out of ideas what to try.

    Wednesday, May 22, 2013 8:48 AM
  • User48 posted

    Indeed, that doesn't make much sense. :-(

    Can you please provide your Device Deployment Logs?

    Thursday, May 23, 2013 1:17 AM
  • User10473 posted

    Attached is my log. Hopefully you can see whats up as its now at the point I cant deploy/debug at all :(

    Thursday, May 23, 2013 8:06 AM
  • User48 posted

    Thank you. I see that we are attempting to create the fast deployment directory, but it's not being created:

    Mono.AndroidTools.AndroidLogger Verbose: 0 : [D:RunShellCommand]:      HT25RW100732 am broadcast -a mono.android.intent.action.SEPPUKU -c mono.android.intent.category.SEPPUKU.DTEPlayAIM.DTEPlayAIM DTEPlayAIM.DTEPlayAIM/mono.android.Seppuku
    Mono.AndroidTools.AndroidLogger Verbose: 0 : -- Start GetRemoteFileInfo - 05/23/2013 09:03:37 (12.0012ms) --
    Mono.AndroidTools.AndroidLogger Verbose: 0 : [INPUT] /data/data/DTEPlayAIM.DTEPlayAIM/files/.__override__
    Mono.AndroidTools.AndroidLogger Verbose: 0 : [OUTPUT]
    ---------
    Mono.AndroidTools.AndroidLogger Verbose: 0 : -- End GetRemoteFileInfo --
    

    Can you please provide the Android Debug Log output? In particular, is the DTEPlayAIM.DTEPlayAIM process being started?

    Thursday, May 23, 2013 2:54 PM
  • User10473 posted

    I dont understand as to why its trying to create a fastdev directory when i have the option unchecked within settings? The DTEPlayAIM process starts, fails when Syncronizing Assets.

    Thursday, May 23, 2013 3:15 PM
  • User1504 posted

    It looks like this is a bug in Xamarin Studio, is it possible to add Full in the PropertyGroup for Debug|AnyCpu and this should get it up and running again

    Thursday, May 23, 2013 3:45 PM
  • User10473 posted

    What do you mean by 'adding Full to the PropertyGroup'?

    Thanks

    Thursday, May 23, 2013 3:47 PM
  • User1504 posted

    Into .csproj file

    Friday, May 24, 2013 10:14 AM
  • User216 posted

    Thanks @alberto.p ... that seemed to help with my case

    You need to add:

    <DebugType>full</DebugType>
    

    It wasted a couple of hours :( ... but I can deploy again :)

    Friday, May 24, 2013 10:18 AM
  • User10473 posted

    Still no joy. Mine was already set to full.

    Friday, May 24, 2013 10:42 AM
  • User10473 posted

    Again, really struggling with this. Spent hours searching and trying out the suggestions above, but still no luck.

    Tuesday, May 28, 2013 7:50 AM
  • User1568 posted

    Have you contacted support@xamarin.com directly? And filed a report on bugzilla?

    Also please attach the full Android Debug Log as @jonp requested.

    Tuesday, May 28, 2013 1:02 PM
  • User10473 posted

    I have just emailed them. I dont know how to attach the log file other than copy and pasting the whole lot within a txt file.

    Tuesday, May 28, 2013 1:05 PM
  • User1568 posted

    I dont know how to attach the log file other than copy and pasting the whole lot within a txt file.

    Yep, and just attach that file here.

    Tuesday, May 28, 2013 2:09 PM
  • User10473 posted

    attached

    Wednesday, May 29, 2013 12:40 PM
  • User1568 posted

    Thanks, hopefully this helps @jonp.

    I've seen this issue two times now as well - on Xamarin.Android 4.6.7. But this may have just been a rare glitch. I have not been able to reproduce it.

    Wednesday, May 29, 2013 10:52 PM
  • User48 posted

    @SamualCartner: Thank you for the log file. The relevant lines are:

    05-28 13:49:05.030 F/MonoDroid( 6656): No assemblies available. Assuming this is part of Fast Deployment. Exiting...
    05-28 13:49:05.150 D/Zygote  (  144): Process 6656 exited cleanly (65)
    

    There are two places that assemblies can be stored: within the .apk, and in the fast deployment directory. If no assemblies are found during process startup, then process aborts with the above error message.

    Sanity check time:

    1. Does your .apk contain assemblies?

      unzip -l path\to\your\app.apk | grep .dll$
      
    2. If your .apk doesn't contain assemblies, does nuking your bin and obj directories and rebuilding change anything?

    3. Can you provide your .csproj contents?

    4. Which Configuration are you building?

    Within your .csproj, for the <ProjectGroup/> for the Configuration you're building, you need to double-check that:

    1. <AndroidUseSharedRuntime/> is False.
    2. <EmbedAssembliesIntoApk/> is True.
    Thursday, May 30, 2013 4:15 AM
  • User10473 posted

    Many thanks for all your help guys, but after talking to support direct, I have finally fixed the issue.

    I tried using a Samsung Galaxy Tab to deploy my app to, and all worked great, every time. I was then advised by support to try using Xamarin Studio,which when using my htc ONE x, still gave me the FastDev error, but with the Galazy Tab, all worked great.

    I then noticed within the project/android properties that FastDev was checked to be used, however this was not the case within Visual Studio. I unchecked the FastDev option, and now deploys great to my htc ONE x in both Xamarin Studio and now Visual Studio. Im guessing there is a bug within my Visual Studio/Xamarin which doesnt correctly allow you to enable/disable FastDev.

    Fingers crossed its all ok from now on. But again, many thanks to you all for the help.

    Thursday, May 30, 2013 7:44 AM
  • User3932 posted

    This is still an issue: could not get fast deployment working in VS2012. Fiddling with the deployment options in XS solved it.

    BTW my breakpoints were ignored, too, but those are working now also.

    Friday, September 20, 2013 9:16 AM
  • User738 posted

    Any status on this FastDev issue via Visual Studio plugin? I am using version 1.8 and I am still getting having this issue.

    Saturday, November 23, 2013 1:32 AM
  • User8228 posted

    Have you tried this?

    http://forums.xamarin.com/discussion/2339/deployment-failed-fastdev-directory-creation-failed

    Thursday, January 2, 2014 8:45 PM
  • User1798 posted

    This was fixed for me by applying the settings Jon P suggested: to False. to True.

    Toggling the "Shared Runtime" checkbox in Visual Studio, while in the release config sorted it out.

    The "Use Fast Deployment" checkbox was checked (and disabled) before, but now it's unchecked.

    I was also seeing this: https://bugzilla.xamarin.com/show_bug.cgi?id=11780

    Saturday, August 30, 2014 6:50 PM
  • User32603 posted

    @JonathanPryor said: 2. <EmbedAssembliesIntoApk/> is True.

    This did the trick for me.

    Friday, February 17, 2017 10:51 AM