none
Workspace creation error RRS feed

  • Question

  • Hi,

    I have some problems when create a new project workspace when use a custom template, here the error

    CreateWssSiteContent: Creating project site failed! Project Uid=a395e7f6-8023-4d3c-a7db-ce91169f0ef0, site URL=http://qadem0/PWA/test, 
    site name=dedededdeddeddededded. System.Runtime.InteropServices.COMException (0x8107058A): <nativehr>0x8107058a</nativehr><nativestack></nativestack>Microsoft.SharePoint.
    SPException at Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb,
     Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl,
     String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)Microsoft.SharePoint.SPException: Microsoft.
    SharePoint.SPException ---> System.Runtime.InteropServices.COMException (0x8107058A): <nativehr>0x8107058a</nativehr><nativestack></nativestack>Microsoft.SharePoint.SPException at 
    Microsoft.SharePoint.Library.SPRequestInternalClass.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, 

    Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, 
    String bstrWebTemplateContent, Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId)
     --- End of inner exception stack trace --- at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx) at Microsoft.SharePoint.Library.SPRequest.ApplyWebTemplate(String bstrUrl, String bstrWebTemplateContent,
     Int32 fWebTemplateContentFromSubweb, Int32 fDeleteGlobalListsWithWebTemplateContent, String& bstrWebTemplate, Int32& plWebTemplateId) at Microsoft.SharePoint.SPWeb.ApplyWebTemplate(String strWebTemplate)
     at Microsoft.SharePoint.SPSite.CreateWeb(String strUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, Boolean bCreateUniqueSubweb, Boolean bConvertIfThere, Guid webId, 
    Guid rootFolderId, Boolean createSystemCatalogs) at Microsoft.SharePoint.SPSite.SPWebCollectionProvider.CreateWeb(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate,
     Boolean bCreateUniqueSubweb, Boolean bConvertIfThere) at Microsoft.SharePoint.SPWebCollection.Add(String strWebUrl, String strTitle, String strDescription, UInt32 nLCID, String strWebTemplate, 
    Boolean useUniquePermissions, Boolean bConvertIfThere) at Microsoft.Office.Project.Server.BusinessLayer.Admin.CreateSPWeb(SPSite topSite, String spWebUrl, String spWebName, String spWebDescription, 
    String spWebLogoUrl, Int32 webTemplateLCID, String webTemplateName, String& errorMessage):
    WSSCreateSiteFailure (16400). Details: id='16400' name='WSSCreateSiteFailure' uid='d503aa16-bb7d-479d-9dd9-d3935da669a5' projectUID='a395e7f6-8023-4d3c-a7db-ce91169f0ef0' 
    workspaceUrl='http://qademo/PWA/test/test' projectWorkspaceName='dedededdeddeddededded'. 
    Queue:
    GeneralQueueJobFailed (26000) - CreateWssSite.CreateWssSiteMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='a33770c0-78ae-4bfc-9415-87e4928685ce'
     JobUID='4892534c-5d6c-4aa7-adb3-103ed6366660' ComputerName='OMNIA' GroupType='CreateWssSite' MessageType='CreateWssSiteMessage' MessageId='1' Stage=''.
     For more details, check the ULS logs on machine OMNIA for entries with JobUID 4892534c-5d6c-4aa7-adb3-103ed6366660. 


    • Edited by Ray Chapa Tuesday, November 6, 2012 9:38 PM
    Tuesday, November 6, 2012 9:38 PM

Answers

  • I solved, for strange reason something is wrong with the Queue service, I restarted and everything works again, now I be able to create my WP with any template, I hope this help for similar issue.

    Thanks!


    Raymundo Chapa, MCTS http://www.inavant.mx/blog http://projectaserverzone.blogspot.com/

    • Marked as answer by Ray Chapa Tuesday, November 20, 2012 5:15 PM
    Wednesday, November 7, 2012 6:08 AM