none
SharePoint Web services removed while deleting extended web application

    Question

  • Please help to get the solution to recover SharePoint Web services from Sites in IIS 7.

    I am using SharePoint 2013 site

    Thursday, January 10, 2019 3:40 PM

All replies

  • Do you have the root folder? How many servers in the farm do you have? can you get a copy of the root folder "Webservice"?

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebServices

    Here is is powershell script which can help us to get all the running service back under IIS with their GUID.

     

    $webservice = [System.Type]::GetType("Microsoft.SharePoint.Administration.SPIisWebServiceSettings, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c")

     

     

    $Instance = $webservice::Default

    $Method = $webservice.GetMethod("ProvisionLocal", "Instance, NonPublic", $null, @(), $null)

    $Method.Invoke($Instance, $null)

    $Method = $webservice.GetMethod("Provision", "Instance, Public", $null, @(), $null) 

    $Method.Invoke($Instance, $null)

    Once we are done with about script we should have “SharePoint Web Service” under IIS with only few information.

    now we need to get all the respective VD in IIS.

    Get-SPServiceApplication | ForEach-Object {$_.Provision()}

     

    Above steps should helps us to get the missing VD and Sharepoint Webservice back in IIS.

    Hope this helps!

    ---------------------------------------------------------------------------------------------------------

    Please don't forget to “mark the replies as answers” if they helped, also set "like" it’s a boost for us to keep blogging J

    Click here to learn more. Visit the dedicated Community forum to shareexplore and talk to experts about Microsoft Kaizala.


    <footer class="entry-footer single" style="box-sizing:border-box;font-size:14px;color:#333333;font-family:'Segoe UI', Tahoma, Arial, 'Helvetica Neue', Helvetica, sans-serif;"></footer>



    Thursday, January 10, 2019 5:01 PM
  • Hi Rahul Amrutkar,

    I agree with Thuyavan Ganesan.

    However, the location of the root folder "Webservice" in SharePoint 2013 is:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\WebServices\

    Refer to this link for more:

    https://anothersharepointblog.com/re-creating-the-sharepoint-web-services-site

    Best Regards,

    Michael Han


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, January 11, 2019 8:45 AM
  • Check the article,

    https://blogs.msmvps.com/haarongonzalez/how-to-restore-the-sharepoint-web-services-iis-web-site-if-accidently-deleted/

    We need to re-provision it

    $h = Get-SPServiceHostconfig
    $h.Provision()
    $services = Get-SPServiceApplication
    foreach ($service in $services) { $service.provision();
    write-host $service.name}

    Regards

    Prasad Tandel

    Friday, January 11, 2019 2:38 PM
  • Hi Rahul Amrutkar,

    Is there anything to update? 

    Please remember to mark the reply as an answer if it helps. 

    Have a nice day!

    Best Regards, 

    Michael Han 



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, January 21, 2019 6:07 AM