locked
Get warning when try to run bat file from sharepoint 2013 - Some file could harm your computer RRS feed

  • Question

  • When try to run bat file from SharePoint 2013 get warning This type of file could harm your computer

    Also Run option is not available, Save and Run is disable.

    Thanks,

    Jitendra

    Wednesday, May 7, 2014 11:02 AM

Answers

  • The issue resolution is to remove the warning message, not to provide a Run option.  I don't think there is a way to provide a Run Option when downloading a Batch file from 2013.  The things I would check are as follows:

    1) Make sure the site is listed in Trusted Sites Zone in IE.

    2) Make sure the web application hosting the site is set for "Permissive" handling in the Web Application General Settings.

    Security settings are tighter in 2013 than they were in 2010.  you can get rid of the prompt but I'm not sure you can get supply the run option while downloading.


    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Thursday, May 8, 2014 11:48 AM

All replies

  • This is by design.  When you try to run a .BAT file directly from a location stored in SharePoint 2013 you are downloading and running an executable from the Internet.  That is the normal pattern for a virus.  So Microsoft doesn't allow that particular pattern.  You would need to download and save the file and then run it locally, after being warned that it is dangerous to run an executable that you find on the Internet unless you know exactly where they are coming from.

    The warning is actually generated by your workstation, not SharePoint.  It can be disabled using the following instructions, but I don't recommend it since it is a reasonable reminder.  The link is for XP, but the process is still pretty much the same for any Windows OS.

    http://www.ehow.com/how_5804009_disable-security-warning-windows-xp.html


    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Wednesday, May 7, 2014 11:33 AM
  • Hi Paul,

    I have tried this solution but issue not resolved, it's ask to save only.

    I am having different environment with SP server 2010 on windows server 2008 R2 and on this getting run option.


    Wednesday, May 7, 2014 11:55 AM
  • The solution has to be applied to each workstation, not the server.  Its caused by the browser, not by SharePoint.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Wednesday, May 7, 2014 1:29 PM
  • Yes, I have applied it on client's workstation,

    But issue is not resolved.

    as above, issue is not coming on client's workstation when open bat file from SharePoint 2010 site, but on same workstation facing issue with SharePoint 2013 site. 

    Thursday, May 8, 2014 5:02 AM
  • I'm a little confused, you have 2010 on 2008R2 and 2013 on 2012. The second screen shot doesn't appear to show either, as that's a Windows 7 toolbar. That could just be because the RDP session isn't full screened but that's not certain.

    On the Server 2012 system, can you download and run files from the SharePoint 2010 environment but not the 2013 environment?

    I'm not sure this is a good idea, the concept of storing batch files in SharePoint and then allowing instant download and run behaviour strikes me as risky.

    Thursday, May 8, 2014 11:13 AM
  • The issue resolution is to remove the warning message, not to provide a Run option.  I don't think there is a way to provide a Run Option when downloading a Batch file from 2013.  The things I would check are as follows:

    1) Make sure the site is listed in Trusted Sites Zone in IE.

    2) Make sure the web application hosting the site is set for "Permissive" handling in the Web Application General Settings.

    Security settings are tighter in 2013 than they were in 2010.  you can get rid of the prompt but I'm not sure you can get supply the run option while downloading.


    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Thursday, May 8, 2014 11:48 AM

  • On the Server 2012 system, can you download and run files from the SharePoint 2010 environment but not the 2013 environment?

    Yes, When click  on bat file from SharePoint 2010 environment it gives option to run means no need to save file locally, and when try this using SharePoint 2013 environment it's not giving opting to run directly without download it locally.

    Also try this on Windows 7 client workstation,

    Please find attach snaps.


    Thursday, May 8, 2014 11:59 AM
  • Thanks Paul,

    Issue resolved after set Browser File Handling is permissive.

    Thank you very much.

    Thursday, May 8, 2014 12:17 PM