locked
Azure SignalR Service uses non-standard HTTPS ports RRS feed

  • Question

  • User-1681143053 posted

    We are using Azure Signal R Service, however we noticed that the negotiate request will inform the client to re-route to Azure Signal R service URL on a non standard HTTPS port (5001).

    Our corporate firewall/proxies will block HTTP traffic not on port 443.  

    Is there anyway to tell Azure Signal R service to use 443?

    Monday, June 11, 2018 2:28 PM

All replies

  • User61956409 posted

    Hi pbleess,

    Is there anyway to tell Azure Signal R service to use 443?

    It seems that you’d like to change port for your Azure SignalR Service from 5001 to 443. I check the Azure SignalR Service on Azure portal and Azure CLI, I do not find it enables us to configure ports for Azure SignalR Service, it is managed by Azure.

    Our corporate firewall/proxies will block HTTP traffic not on port 443.  

    If possible, you can contact the network administrator to modify the firewall rule to enable 5001 port.

    With Regards,

    Fei Han

    Tuesday, June 12, 2018 10:02 AM
  • User-202200401 posted

    Hi pbleess,

    I agree this is a valid scenario, but currently there is no way to customize the port. I've opened a work item in our backlog:

    https://github.com/Azure/azure-signalr/issues/123

    will keep you updated once there is any progress in this one.

    Wednesday, June 13, 2018 8:48 AM
  • User-900074593 posted

    I also face the same issue. It would be nice if azure service library allows the user to customize the port settings.

    Monday, July 9, 2018 7:27 PM
  • User1834014264 posted

    Yep, I'm having the same problem.

    It would be wonderful if the default port could be 443 and if we could configure which port we want to use...

    Tuesday, July 10, 2018 3:17 PM