locked
AzurePoc Deployment Error: Create FailoverCluster RRS feed

  • Question

  • Hi,

    any help is highly appreciated as I don't know what else to do. The deployment fails during "CreateFailoverCluster". The logs (fabric installer and event logs) didn't help any.

    I checked the Failover Cluster Manager again "Connecto to Cluster" and there is the ASCluster. So it is created - I checked properties on cluster IP/ Virutal Machine Cluster WMI and everything is "Online" and in properties no DNS etc. error...

    I do not understand why it fails as the cluster is created and shows no error.

    I restarted the deployment, hopping it would move on with the installation... instead it destroys the cluster and starts creating it again... failing again...

    Tried a manual install of the Cluster. During cluster validation I receive an error that no domain server is reachable. BUT nslookup and ping to the ADVM.azurestack.local works fine. The Hyper-V Host is visible in DNS and the computer account is in AD. So not sure why this error appears.

    The only thing I can think of is the strange IP configuration: my only active NIC has a 192.168.1.0 subnet but AD VM has 192.168.100.0. The cluster IP I see is also 192.168.100.X. When looking at the physical host and AD VM both have a second IP of 192.168.5.5 - I have not idea what this IP is used for.

    Any ideas are highly appreciated.

    Friday, June 3, 2016 1:09 PM

All replies

  • Hi Sroe,

    Thank you for posting here!

    Before you create a cluster, you must carry out tasks such as connecting the hardware and validating the hardware configuration. For a list of these tasks, see Checklist: Create a Failover Cluster.

    If the DNS client can ping the DNS server computer, verify that the DNS server is started and able to listen to and respond to client requests. Try using the nslookup command to test whether the server can respond to DNS clients.

    Here is an article for Troubleshooting DNS servers.

     

    Regards,

    Pradeep

    Saturday, June 4, 2016 3:35 AM
  • Hi,

    I am aware of that. As I stated the Cluster gets created and it doesn't show any errors. But the deployment script - for whatever reason - gives an error message.

    I checked DNS and AD again but found no errors there.

    I re-installed the OS using TP4 (as it had been working with this version before) and installation runs through without errors. So I seem to have a problem with TP5. Will do more tests...

    Saturday, June 4, 2016 9:33 PM
  • Hi,

    Please be advised that Windows Server 2016 Datacenter Edition Technical Preview 4 EN-US (Full Edition) is the version supported currently.
    TP5 is not yet supported, that might explain the issue.
    You could refer the following link for details on deploying Azure Stack POC:
    https://azure.microsoft.com/en-us/documentation/articles/azure-stack-run-powershell-script/

    Regards,
    Malar.

    Tuesday, June 7, 2016 3:59 AM
  • Hello,

    I also tried TP5 and had a hard time getting the PoC to complete -I was able to get it to complete by letting the installer fail, open powershell on the PoC host run Enable-ClusterStorageSpacesDirect which will create the storage pool for the cluster. open the deployfailovercluster.ps1 in ISE and delete from lines 25 to 124 - which leaves removing the unused binding. rerun the POC installer and the cluster finishes.

    Obviously 100% unsupported but it works!


    If this post answered your question, Mark As Answer If this post was helpful, Vote as Helpful ---------------------------------------------------------- http://lyncme.blogspot.com

    Sunday, July 10, 2016 12:44 PM