locked
ASP timeout value not updating correctly RRS feed

  • Question

  • MS Server 2000

    MS SQL Server 2003

    Connection timeout not updating correctly.  In Enterprise Manager I updated from 600 to 900 seconds.  I had some connections issues and the solution said to modify the properties of the DB user to grant it 'write' privilege.  It solved the first issue but now it is timing out after 300 seconds.  After searching again I saw something about modifying the timeout for the user.  Could this be the solution and how do you do that.

    Classic ASP.  In the code I use:

    Server.CreateObject("ADODB.Command")

    Thank you in advance.

    Monday, June 2, 2014 10:34 PM

Answers

  • Hello,

    You can try to using the CommandTimeout property to specify the number of seconds to wait while attempting to execute a command. For example:

    set comm=Server.CreateObject("ADODB.Command")
    comm.CommandTimeout=600

    Reference:http://www.w3schools.com/ado/prop_commandtimeout.asp

    Regards,
    Fanny Liu


    Fanny Liu
    TechNet Community Support


    • Edited by Fanny Liu Wednesday, June 4, 2014 3:59 AM edit
    • Proposed as answer by Olaf HelperMVP Wednesday, June 4, 2014 5:58 AM
    • Marked as answer by Fanny Liu Friday, June 13, 2014 1:06 AM
    Wednesday, June 4, 2014 3:59 AM

All replies

  • Hello,

    You can try to using the CommandTimeout property to specify the number of seconds to wait while attempting to execute a command. For example:

    set comm=Server.CreateObject("ADODB.Command")
    comm.CommandTimeout=600

    Reference:http://www.w3schools.com/ado/prop_commandtimeout.asp

    Regards,
    Fanny Liu


    Fanny Liu
    TechNet Community Support


    • Edited by Fanny Liu Wednesday, June 4, 2014 3:59 AM edit
    • Proposed as answer by Olaf HelperMVP Wednesday, June 4, 2014 5:58 AM
    • Marked as answer by Fanny Liu Friday, June 13, 2014 1:06 AM
    Wednesday, June 4, 2014 3:59 AM
  • In Enterprise Manager I updated from 600 to 900 seconds. 


    You modified the "Remote query timeout" in the Server settings (for e.g. linked Server), but your issue is caused by a command timeout; that's something different. See Fanny's answer how to solve this.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Wednesday, June 4, 2014 5:57 AM