none
WEC 7 MSB4018: The "SetImageLangIdBootAppropriately" task failed unexpectedly RRS feed

  • Question

  • Working on VS 2008 and WEC 7.  I am trying to build the sample project from  https://beaglebonebsp.codeplex.com/ for the Beaglebone.  I am getting the following error: MSB4018: The "SetImageLangIdBootAppropriately" task failed unexpectedly.  Seen one post on here that appears related but no luck with it.  Anyone have any ideas.  Thanks

     BUILDREL: BUILDMSG: Calling W:\WINCE700\OSDesigns\AM33X_BBB\AM33X_BBB\pbuildrel.proj
    BLDDEMO: BUILDMSG: Calling Makeimg -- Please Wait
      MAKEIMG: BUILDMSG: Calling W:\WINCE700\public\common\oak\misc\pbpremakeimg.bat
      PBPreMakeImg: BUILDMSG: Generating OS design Custom makeimg build step batch Files to W:\WINCE700\OSDesigns\AM33X_BBB\AM33X_BBB\Wince700\AM33X_BBB_BSP_ARMV7_Debug\oak
      PBPreMakeImg: BUILDMSG: Done Generating OS design Custom makeimg build step batch Files 
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018: The "SetImageLangIdBootAppropriately" task failed unexpectedly. {log="W:\WINCE700\build.log(13398)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018: System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B) {log="W:\WINCE700\build.log(13399)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.PlatformBuilder.Build.Makeimg.Tasks.SetImageLangIdBootAppropriately.SetImageLangIdBootAppropriatelyCall() {log="W:\WINCE700\build.log(13400)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.PlatformBuilder.Build.Makeimg.Tasks.SetImageLangIdBootAppropriately.Execute() {log="W:\WINCE700\build.log(13401)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute() {log="W:\WINCE700\build.log(13402)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext() {log="W:\WINCE700\build.log(13403)"}
      W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018: The "SetImageLangIdBootAppropriately" task failed unexpectedly. {log="W:\WINCE700\build.log(13410)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018: System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B) {log="W:\WINCE700\build.log(13411)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.PlatformBuilder.Build.Makeimg.Tasks.SetImageLangIdBootAppropriately.SetImageLangIdBootAppropriatelyCall() {log="W:\WINCE700\build.log(13412)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.PlatformBuilder.Build.Makeimg.Tasks.SetImageLangIdBootAppropriately.Execute() {log="W:\WINCE700\build.log(13413)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute() {log="W:\WINCE700\build.log(13414)"}
    W:\WINCE700\public\common\oak\misc\makeimg.proj(546,5): error MSB4018:    at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext() {log="W:\WINCE700\build.log(13415)"}
    BLDDEMO: ERROR: Error(s) in makeimg phase. See W:\WINCE700\build.log for details. {log="W:\WINCE700\build.log(13422)"}
    BLDDEMO: BUILDMSG: BldDemo ended at  8:54:41.03 on Mon 05/26/2014 (exit code 1)
    BuildLogs: BUILDMSG: Exiting: BldDemo1.bat  -q (result code 1).

    Thursday, May 29, 2014 6:01 AM

All replies