Problem with Azure Endpoint at Ubuntu. RRS feed

  • Question

  • Hi All,

    I got a problem with Azure Endpoint using Ubuntu.


    Online port scanner reported that port 1194 is closed even though the End point was defined to be open at Azure Web Interface for that VM


    UFW, aka Ubuntu Firewall is inactive.

    No IP Table was defined in Ubuntu

    On Azure web management interface, endpoint called VPN, port 1194 was set to open, bidirectional allowing direct return. Public and Private port is both 1194

    lfor and netstat on ubuntu reported thata service is listening on 1194


    From Ubuntu, I can see the internet. Pinging Google, getting updates works fine.

    I can remote into the machine using default port 22, which is a default open endpoint defined by Azure Ubuntu Image

    Restarted Ubuntu everytime a setting change.

    Tried deleting and  re-creating Endpoint rule, failed

    Tried shutting down the VM, and delete and recreate endpoing rule, failed.

    Tried a different endpoint, 443, failed.

    Troubleshooting Steps performed

    From my local computer, unable to telnet to the Ubuntu server via 1194. Ok on 22, terminated because of protocol mismatch, but that is of course fine.

    Online port scanners all report that 1194 was closed.

    Some help would be appreciated.

    • Moved by BrianEhMVP Monday, October 12, 2015 3:11 PM
    Sunday, October 11, 2015 9:14 PM


  • Hi,

    Please, can you create another virtual machine on the same subnet and try the test from within that machine. I see that your troubleshooting steps are good but i saw many issues with Azure endpoints that finally are related to the OS itself

    Regards, Samir Farhat || Datacenter Consultant || The way to share my knowledge with the community Visit my blog : buildwindows.wordpress.com buildwindows.wordpress.com </a>

    Monday, October 12, 2015 4:37 PM