none
where to Turn off validation in the schema annotation RRS feed

  • Question

  • Message Is Suspended with EDI Validation Turned Off

    Symptom

    A paired rule is violated, and validation is turned off, but the message is suspended (expected results are that the message is serialized).

    Possible Cause

    Cross-field/segment validation is performed, even if EDI type property is deselected in the Validation and ACK Generation Settings node of the EDI Properties dialog box. Validation occurs because it is turned on in the schema annotation.

    Resolution

    Turn off validation in the schema annotation.

     

    Turn off validation in the schema annotation.

    Where do I do this.. 

     

    Thanks


    Krishna
    • Edited by Krishna Kal Wednesday, November 9, 2011 4:43 PM
    Wednesday, November 9, 2011 4:32 PM

Answers

  • In the BizTalk EDI Schema search for X12ConditionDesignator_Check

    Change the value from 

    X12ConditionDesignator_Check="Yes"

    to

    X12ConditionDesignator_Check="No"

     

    This turns off the Cross Field/Segment validation.

    Walter

     

     


    Please mark this as answered if it helps. Walter Michel http://geekswithblogs.net/wmichel
    Thursday, November 10, 2011 11:50 PM