none
Increase receive timeout RRS feed

  • Question

  • This request operation sent to net.tcp://XYZ/ICONTRACT did not receive a reply within the configured timeout (00:01:00).  The time allotted to this operation may have been a portion of a longer timeout.  This may be because the service is still processing the operation or because the service was unable to send a reply message.  Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client.
    Monday, July 15, 2019 11:49 AM

All replies

  • You have provide no code or context so we have no idea what you're talking about.  If this is related to WCF then please post in the WCF forums.

    Michael Taylor http://www.michaeltaylorp3.net

    Monday, July 15, 2019 2:10 PM
    Moderator
  • Hi Shraddhesh,

    Thank you for posting here.

    Since this thread is related to WCF, I will move it to Windows Communication Foundation, Serialization, and Networking forum to get support.

    The Visual C# forum discusses and asks questions about the C# programming language, IDE, libraries, samples, and tools.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, July 16, 2019 2:32 AM
  • Hi,
    The error mainly suggest we increase the OperationTimeout property, but I do not think it is a main reason caused the issue.
    https://docs.microsoft.com/en-us/dotnet/framework/wcf/feature-details/configuring-timeout-values-on-a-binding
    In my opinion, the issue is caused by some other reasons, such as the authentication error, we might need to provide a client credential.
    I would like that you could post more details about the server binding configuration and the client configuration. I try to reproduce your issue and locate where the problem specifically lies.
    Besides, please enable the IIS support for NetTcp protocol and close the firewall.
    https://i.stack.imgur.com/EbnJL.png
    Best Regards
    Abraham
    Tuesday, July 16, 2019 7:32 AM
    Moderator