none
Emulator problem when creating SDK for a custom run time image based on emulator BSP RRS feed

  • Question

  • Hello everybody,

    I have the following scenario, based on Windows Embedded 6.0 R3:

    1) I cloned device emulator BSP to build a custom image based on it.

    2) Created new OS design and selected the cloned BSP as the target.

    3) Customized the OS design and build it and everything went just fine, I can launch my custom image using attach device option from target menu.

    4) Created a new SDK so that I can use it to create new applications separately from the OS design project.

    5) The emulation options of the SDK are disabled and can't be modified, so I left it as it is.

    6) I built the SDK, installed it, created a new application project, build it, tried to launch the emulator, but the only thing I have is a black screen.

    So, what is the problem with that? Is there any missing step I didn't do? I have read here that in order to enable Emulator support in SDK I have to add support for the device emulator BSP to my OS design, but my OS design is built on a clone of device emulator BSP.

    Thank you guys, and any help is highly appreciated.

    Thursday, August 12, 2010 6:53 AM

All replies

  • Hi,
     
    Check out this blog post for debugging application on Emulator using Active sync.Hope this helps you.
     
    Thursday, August 12, 2010 8:37 AM
  • Thank you Prabu for you answer, but the following happened: I tried the described method before adding the system variables and modifying platform.dat, ActiveSync tried to connect to the emulator, but gave an message after a while saying that it couldn't connect to the device and try one of the following 2 options which I forgot, so I said maybe after make the modifications as you described in your blog, it will connect successfully, but after I built the OS and tried again, ActiveSync now doesn't even recognize that a device is trying to connect when I press Cradle from the menu, nothing happens at all.

    By the way, this is the content of platform.dat file after your suggested modifications.

    ;
    ; Copyright (c) Microsoft Corporation.  All rights reserved.
    ;
    ;
    ; Use of this sample source code is subject to the terms of the Microsoft
    ; license agreement under which you licensed this sample source code. If
    ; you did not accept the terms of the license agreement, you are not
    ; authorized to use this sample source code. For the terms of the license,
    ; please see the license agreement between you and Microsoft or, if applicable,
    ; see the LICENSE.RTF on your install media or the root of your tools installation.
    ; THE SAMPLE SOURCE CODE IS PROVIDED "AS IS", WITH NO WARRANTIES.
    ;

    ; During cold boot, copy \Windows\DMACnect.lnk to \Windows\Startup in RAM

    Directory(LOC_DIRWINDOWSSTARTUP):-File("DMAcnect.lnk","\Windows\DMAcnect.lnk")

    ;IF IMGTPC
    ;Directory(LOC_DIRWINDOWSSTARTUP):-File("DMAcnect.lnk","\Windows\DMAcnect.lnk")
    ;ENDIF ; IMGTPC

    IF IMGPPC
    {BEGIN MULTILANG}
    Directory(LOC_%LANGID%_DIRWINDOWSSTARTUP):-File("DMAcnect.lnk","\Windows\DMAcnect.lnk")
    {END MULTILANG}
    ENDIF ; IMGPPC

    Thursday, August 12, 2010 9:51 AM
  • Make sure you have added Active Sync related catalog item while creating OSdesign.

    And also try reinstalling active sync software on your development PC.

    What is the error message you are getting while trying to cradle?

    --
    Regards,
    Prabu
    http://prabukumar.wordpress.com/
    www.e-consystems.com

    Thursday, August 12, 2010 11:50 AM
  • Well, I am sure I added the ActiveSync catalog.

    I will try to reinstall ActiveSync.

    That message, which I got before doing the steps found in your article, was saying something like ActiveSync can't connect to the device, either because its not well connected, and I can't remember the other option. Maybe I will undo the changes I made to the OS design then build it to see if I will have the same message or not, and tell you what I get.

    Regards,

    Ayman

    Thursday, August 12, 2010 11:58 AM
  • Here is the error message.
    Thursday, August 12, 2010 1:07 PM
  • While giving Cradle in the device emulator manager on the PC ,did you get any pop up window on the WinCE emulator screen?
     
    Thursday, August 12, 2010 2:30 PM
  • Yes, I noticed that connecting screen the first time I cradled it, but after that it no longer appears, even I uncradled it, or close it and open it again.
    Thursday, August 12, 2010 3:05 PM
  • Hi all and thanks

    i have same problem exactly

    what can i do?

    i guess that bsp cloning is a fault in this progress

    but i will have very better life !!! if this problem be solved.

     

    thanks to all

    Wednesday, May 11, 2011 10:29 AM
  • Hi all

    thank again from Michael Koster for his answer to my same question

    this problem solved by just using original DeviseEmulator BSP in OS image creating.

    for enable the Emulator option you must Use original DeviceEmulator BSP and

    don't use Cloned BSP.

     

    Thank All

    Moein

     

    • Proposed as answer by Moein Karimi Friday, May 13, 2011 5:57 AM
    Friday, May 13, 2011 5:56 AM