locked
[WPSL8.1] Problem with tail updates RRS feed

  • Question

  • Hello,

    i've got Windows Phone Silverlight 8.1 application in store. App uses MPN notification service and updates tiles by the following code : 

    var tile = ShellTile.ActiveTiles.FirstOrDefault();
    tileData = new FlipTileData
    {
    	BackgroundImage = new Uri(external_url),
    	WideBackgroundImage = new Uri(external_url)
    };
    tile.Update(tileData);
    

    App was last updated in the store in 2014 using VS2013 and everything worked ok on WP8.1 and WM10.
    In backend iis logs i've got user agent : HTTP/1.1 ZDM/4.0;+Windows+Mobile+8.1

    Running the same code on VS2015 on emulator or directly on phone and tiles works ok.
    In backend iis logs i've got user agent : HTTP/1.1 ZDM/4.0;+Windows+Mobile+8.1

    But the problem started after uploading xap to store, application stops refreshing tiles.
    In backend iis logs i've got user agents : HTTP/1.1 Microsoft-WNS/6.3 and HTTP/1.1 Microsoft-WNS/10.0 but tiles are not showing images.

    What could be the problem?

    Tuesday, October 11, 2016 10:24 AM

All replies

  • The first thing that comes to mind is are you sure the image is available over the internet?
    Tuesday, October 11, 2016 10:58 AM
  • so I checked it several times already, the pictures are available online, the same xap uploaded manually on the phone and tile works ok.

    it seems that xap after loading the store is modified and otherwise trying to appeal to the tile images

    Tuesday, October 11, 2016 11:09 AM