locked
View file in solution explorer RRS feed

  • Question

  • That's odd, I'm sure I used to be able to double click on an object (in this case a stored procedure) in schema view and it would open for me to edit. Now I just get the menu item 'View file in Solution Explorer' which doesn't work. It just flicks back to the solution explorer and doesn't expand the correct folder or select the correct file.

    Am I mising something?

    Thursday, November 23, 2006 12:52 PM

Answers

All replies

  • I just tried this, when I double click an object it opens the file for edit, and when I click on solution explorer the file is highlighted.

     

    Not sure why you're not seeing this... perhaps try repair in add/remove programs?

    Thursday, November 23, 2006 5:34 PM
  • I also tried and found:

    When double clicking on a stored procedure or view - opens the .sql file immediately.

    When double clicking on a parent (i.e. table which can / does include children) in the schema view such as constraints, indexes, etc.) - nothing happens, switches to solution explorer and the project (not the file) is selected.

    Kind of to be expected I guess. Not sure if it shouldn't go ahead and open the table definition though. Let the guys at usability fight it out.

    Alle

    Thursday, November 23, 2006 6:29 PM
  • Weird, just tried it on my home PC on a table that has child objects and double clicking opened the SQL file fine! Also using the View File in Solution Explorer menu worked OK as well.

    The database schema I have on my home PC is very small in comparison to my work project. I'll try on a smaller project at work tomorrow.

    Thursday, November 23, 2006 9:04 PM
  • Typical, it's working now with the same database! Perhaps it was because it was the same instance of VS2005 I used to check the project into TFS, maybe it screwed something up.

    However, I have noticed something weird about the 'View File in Solution Explorer' option, it doesn't seem to work the first time I use it! When I first use it after opening a database project it switches to the solution explorer, expands the correct folder, but highlights the project file and not the schema file. If I try again it's fine, on all subsequent attempts on all objects.

    I can't seem to upload screenshots at the moment from work, but if you want them then drop an email address here and I'll send them on.

    Friday, November 24, 2006 11:12 AM
  • I have also found that the behaviour is inconsistent. I first thought one box was different than the other but today the same box that wouldn't open the table.sql out of schema view yesterday now does open it (BTW on the first try).

    Alle

    Friday, November 24, 2006 12:04 PM
  • If you can consistently repro it file a bug at http://connect.microsoft.com so we can track the issue....
    Monday, November 27, 2006 5:43 PM
  • I'm not on the DBPro participation list. If you send me an invite I'll log this as a bug.
    Tuesday, November 28, 2006 1:04 PM
  • I'll see if I can figure out how to do this.  If not I'll file it.
    Wednesday, November 29, 2006 6:44 PM