locked
Blockchain workbench RRS feed

  • Question

  • Hi Team,

    I have made sure that my ID is added as guest user in Azure Active Directory in Azure portal(for BLockchain Workbench).

    My teammate has created blockchain application url, when I login with the email ID, I am able to see my ID when I click 

    the membership icon. But when I upload a contract succesfully & when I try to add my ID as Member, I am unable to add my 

    ID. Its not visible.

    I double checked that my ID is added in the Blockchain API client app as an admin.

    Please let me know what needs to be done.

    Thanks in advance!

    Regards,
    Friday, May 11, 2018 1:00 PM

All replies

  • Hi,

    Are you using a separate tenant for your Workbench deployment? Sometimes when provisioning a user from a separate AAD tenant, the first name and last name do not get pulled through. Can you try searching for your email address associated with your user, rather than your name?

    Thanks,


    Microsoft Azure Blockchain Team

    Tuesday, May 15, 2018 7:01 PM
  • Hi Team,

    I have the same problem. I can not find a user to add as a member for Hello, Blockchain application while the user could be seen from the Applications screen. I thought the problem is my domain with large number of users, and I just redeployed Blockchain Workbench on a tenant with just one user. Does not help...

    Best regards,

    Vladimir

    Wednesday, May 16, 2018 5:12 PM
  • Hi Vladimir,

    Could you look at the user properties in your AAD tenant and see if the "First Name" and "Last Name" properties are filled out? If those are not filled out, we default to the user's email address as their first name. If these properties are not set, try searching for your user by searching for the email, rather than their name.

    Thanks,


    Microsoft Azure Blockchain Team

    Wednesday, May 16, 2018 7:16 PM
  • Yes, names are filled. Trying to delete and redeploy again...
    Thursday, May 17, 2018 6:37 AM
  • Hi Vladimir,

    Let us know how the redeployment goes. When possible, can you let us know the search string you are using when trying to add a user to the application?

    Thanks,


    Microsoft Azure Blockchain Team

    Friday, May 18, 2018 5:43 PM
  • I could not deploy the Workbench on corporate tenant. Just bought personal one and everything works. But the issue to deploy it on corporate domain still remains...
    Friday, May 18, 2018 5:48 PM
  • There is a known issue with Workbench right now where searching for users does not work on a tenant with more than 100 users. We have a fix for this and will be releasing it soon.

    Glad to hear it's working, let us know if you have any other issues.

    Thanks,


    Microsoft Azure Blockchain Team

    Friday, May 18, 2018 6:04 PM
  • Hello - Has the fix been released?  I'm having a issue when trying to deploy in my corporate domain.. I see a bunch of users when I search by emails starting with a, but then the number of entries progressively decreases as I search for emails starting with j,k,l,m etc.
    Thursday, May 24, 2018 6:51 PM
  • We are working on it.  We will respond on this thread as soon as we release the fix.

    Microsoft Azure Blockchain Team

    Friday, May 25, 2018 4:00 PM