sharepoint 2013 workflow suspend with 401 error RRS feed

  • Question

  • I am getting below error when I kick off the workflow with user having contribute rights.

    HTTP 401 {"error_description":"The server was unable to process the request due to an internal error.

    x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""

    I reinstalled workflowmanager last week only and it was working till last friday. What can be the exact cause of this 401 error? I need exact answer before we go live.

    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead

    Wednesday, November 6, 2013 7:47 AM


All replies

  • Hi,

    According to your post, my understanding is that sharePoint 2013 workflow suspend with 401 error.

    The point is that we need a User Profile Service to exist, and within it, a profile for whichever user is performing these actions (such as  kick off a workflow).

    Please follow the steps as below:

    1. Be sure User profile synchronization is started.

    2. The user by whom you are logged is available in User Profile list.

    3. Final step full synchronization of User Profile Application.

    Here are two similar threads for you to take a look at:



    Best Regards,

    Linda Li

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

    • Edited by Lindali Thursday, November 7, 2013 2:12 AM
    • Marked as answer by JasonGuo Monday, November 18, 2013 2:09 AM
    Thursday, November 7, 2013 2:11 AM
  • I have the same problem, I have either checked this key-point:

    User profile synchronization is started, I run a Full Synchronization and My web application is associated with Profile Sync Service Proxy, in fact my user has user profile

    I run a IIS Reset

    I developed the workflow with User that belongs to Designer group, not System account

    I still receive message: 

    System.ApplicationException: HTTP 401 {"x-ms-diagnostics":["3001000;reason=\"There has been an error authenticating the request.\";category=\"invalid_client\""],"SPRequestGuid":["cc925f5c-971b-ab66-cfd2-29d3e078d02d"],"request-id":["cc925f5c-971b-ab66-cfd2-29d3e078d02d"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["2651"],"SPIisLatency":["0"],"Server":["Microsoft-IIS\/8.0"],"WWW-Authenticate":["Bearer realm=\"378689cc-7c67-41d1-9dd9-62808f9325c9\",client_id=\"00000003-0000-0ff1-ce00-000000000000\",trusted_issuers=\"00000005-0000-0000-c000-000000000000@*,00000003-0000-0ff1-ce00-000000000000@378689cc-7c67-41d1-9dd9-62808f9325c9\"","NTLM"],"X-Powered-By":["ASP.NET"],"MicrosoftSharePointTeamServices":[""],"X-Content-Type-Options":

    Can anyone help me please? 


    Saturday, October 25, 2014 6:29 AM
  • Hi Linda,

    I am also getting the same error (Workflow goes to Suspended state after 5 mins of start with 401 Exception).

    I have done all the 3 steps but the workflow still gives the same error.

    Please reply as I am stuck on this utterly simple workflow ( just logging (Hello World) to workflow History list for last 2 days.


    Vijay Sharma

    Wednesday, May 20, 2015 9:29 AM
  • Hi,

     I had about the same problem, but now finaly resolved it.

    The SharePoint ULS did'nt gave me any clue.I have checked almost everything that was possible.

    I have a separate dedicated Workflowmanager and a dedicated SP2013 farm


    The Workflow is first started and returns in the Workflow Information the following "internal status" STARTED with the following information:

    Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP Unauthorized to website Correlation Id:  Instance Id: xxxxxxxxx

    After a minute or so it the "internal status" in the Workflow Information changes from STARTED to SUSPENDED with the following information:

    RequestorId:xxxx Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 401 <!DOCTYPE html PUBLIC XHTML 1.0 Strict//EN" "401 Unauthorized. The server requires authorization to fulfill the request. Access to the Web server is denied


    Add mappings of IP addresses to host names in the HOSTS file of your WFmanager (\c:\Windows\System32\drivers\etc\HOSTS

    Add the ip-adress(ess) of the SP2013 webserver(s) with the corresponding webapplication url's (or HSNC) into the hosts file of the Workflowmanager server.Without the http (s).

    Check twice that you didn't misspelled the entry's.

    Check also harbars.net sublime website for more WFmanager installations and confugurations:


    said Zarouk

    • Proposed as answer by EspritAhmed Wednesday, November 25, 2015 1:10 AM
    • Unproposed as answer by EspritAhmed Wednesday, November 25, 2015 1:10 AM
    Wednesday, October 21, 2015 2:23 PM
  • @said Zarouk 

    can you please explain more ?

    i had the same problem and i try all but no luck 

    thanks :)

    Wednesday, November 25, 2015 1:10 AM
  • I found the solution here 


    i hope it helps :)

    Thursday, November 26, 2015 2:35 AM