locked
Trying to access paragraph formatting via alt+o+p but jumps to panels menu RRS feed

  • Question

  • This is a fairly new install of Expression Web 4. We are transitioning from FrontPage 2003 for publishing e-letters.

    The combination Alt+o+p has been working fine as a way to jump to the paragraph formatting window. Suddenly, it started jumping me to the Panels menu. 

    With the Alt+o, the Format item on the main menu bar is highlighted but the dropdown menu does not drop down. When I follow up with the "p", the Panels dropdown menu goes into action.

    Have I accidentally mis-set something. I can still use the Alt+e+s to paste in text-only and the alt+e+e for find/replace.

    I'm stumped. Suggestions?

    Thanks.

    Thursday, May 12, 2016 2:54 AM

All replies


  • You can get a list of shortcuts by going to Help >> Keyboard Shortcuts.  As far as I know there is no way to customize them.  You may be able to do it with the .NET SDK.  I have never used it.
    Thursday, May 12, 2016 2:52 PM
  • >>>You can get a list of shortcuts by going to Help >> Keyboard Shortcuts.  As far as I know there is no way to customize them.  You may be able to do it with the .NET SDK.  I have never used it.

    Thanks. But actually that shortcut -- Alt+O,P -- has always worked to bring up the paragram formatting box. I've used it for years in FrontPage and it was in place for me when I started transitioning to Expression Web 4. A few days ago, however, it stopped working.

    And as I think I noted, the Format dropdown menu does not drop down when highlighted.

    Something has screwed up and maybe I inadvertently changed a setting but have not found anything to indicate that could happen.

    Thursday, May 12, 2016 5:13 PM
  • I don't think anyone here will be able to guess what changed on your computer.  That key combination is not documented in EW's help, but does work in some other Windows applications (Word, Visual Studio,...).  In short, it seems to be a Windows thing, not an EW thing. There isn't any EW setting that would make it stop working.


    Kathleen Wilber
    BrightWillow - ASP.NET applications



    • Edited by KathyW2 Thursday, May 12, 2016 10:04 PM
    Thursday, May 12, 2016 7:21 PM
  • Alt+<menu item letter> is a Windows convention, since at least Win 95, and possibly as far back as Windows 3.0. In fact, some programs have taken to hiding the standard menu bar by default. This can usually be reset in application settings, or you can just press Alt to display the menu and navigate it. EW has no control over this; it simply complies with the UI standard.

    That said, I'm not sure why you're going to all that trouble anyway. All you have to do is right click the opening <p> tag, then in the context menu that pops up, scroll to the bottom and click "Tag Properties...", which will bring up the exact same dialog you get with Alt+o+p. Also note that this will work with most any HTML tag, images, headings, ul, ol, etc., except divs. Not sure why that one's left out, but there you are.

    Anyway, give that a try. Test all the elements you're interested in to see if they work, and let us know if that'll do the job for you...  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    • Edited by paladyn Friday, May 13, 2016 6:16 AM
    Friday, May 13, 2016 4:37 AM
  • What you're discussing is called mnemonics.
    FrontPage was actually part of Microsoft office and used the office mnemonics.
    Expression Web was split from office and became a stand alone in version 2 IIRC.

    Expression Web MVP



    Friday, May 13, 2016 12:23 PM
  • Thanks, Kathy. The shortcut still works fine in Word 10 and in my ol' trusty copy of FrontPage 2003. I'm using Windows 7, BTW.

    Friday, May 13, 2016 2:45 PM
  • Thanks, Scott. Not to delve too much in my background, but I write and intensively edit content plus layout and distribute email newsletters. 

    This time of the year I'm producing 5 e-letters per week on my own and doing 500k keystrokes a month between taking notes and writing content.

    I value shortcuts because taking my hands off the keyboard reduces my productivity.

    It's easy enough for me to use shortcuts because I started with WordStar 35 years ago and never saw a point in using a mouse for word processing, certainly not at the volume of words I have to plow through. Using the same shortcut in FrontPage and now EW4 is a natural transition as I'm pecking around on formatting. CSS and style sheets aren't usable because Gmail (10%-plus of my readership) and a selection of other email platforms either don't work with CSS or misinterpret it. Been there, done that.

    I'm looking for a way to set the world on its axis again.

    Friday, May 13, 2016 2:51 PM
  • Steve...

    Thanks for pointing that out. It hadn't occurred to me that I had been using that same shortcut in Word since the beginning of time (or sometime just after it started). It's such an invisible part of my work life (as are numerous keyboard shortcuts) that I wouldn't even be able to tell you on a spot basis what they are. As noted to an earlier post (once I also saw your comment here) I checked both Word and FP2003 and found that the shortcut worked find there. The problem seems to just exist in EW4.

    Friday, May 13, 2016 3:07 PM
  • I don't think anyone here can tell you how to fix that. We are not Microsoft, and since it's a Windows thing, not an EW thing (in spite of it only being broken in your EW copy), there is nothing about EW's user interface or settings that we can tell you to fix it.

    You are left with the usual things to try: a Restore Point to before it broke, an uninstall and reinstall of the program (although that has rarely been the solution for EW), a repair of your asp.net framework and WPF (part of the framework) installation (although I have no idea if EW's use if Windows Presentation Foundation is tied to this behavior) ... and so on.



    Kathleen Wilber
    BrightWillow - ASP.NET applications

    Friday, May 13, 2016 10:58 PM
  • Another thing to consider, given the nature of the problem, is a hardware issue. If it's not a laptop (or even if it is, if you can plug in an external keyboard), try a different keyboard. Check your keyboard settings in Control Panel, etc. This is a very specific issue, and since it cannot be replicated by anyone else, troubleshooting is not possible by others, and I wouldn't be at all surprised to learn that it was hardware-related.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.

    Saturday, May 14, 2016 7:09 PM
  • Thanks, Scott, for the keyboard suggestion. I will try that, although that doesn't seem like a likely problem since the same shortcut works find in Word and FP2003.

    I also think the command was blown out in another computer on our network, which works on the same files I do. However, I can't check that out right now. The machine is being updated to Win10 and I'm going to wait for the person who uses that computer to finish the install herself, which will be tomorrow.

    I'll let you know.

    Thanks for continuing to consider my situation.

    Warm regard,

    Owen

    Monday, May 16, 2016 2:42 PM