none
Problem with Sharepoint root page redirection to a site page RRS feed

  • Question

  • Hi All,

     

     I am trying to redirect our sharepoint site to a sub page http://site.com/en/pages/Home.aspx when the user calls for http://site.com. I created a default document (default.aspx) in IIS and created a dummy site in IIS. This site has sharepoint application pool and the default document. I use sharepoint foundation 2010. When I call the site, I am always getting 

    404 - File or directory not found.

    When I call http://site.com/default.aspx, the redirection is working properly. Are there any other settings I have to configure. I checked in google and havent found any useful info. 

     

    Any Ideas please share!

     

    Thanks.

     

    Wednesday, August 10, 2011 8:29 AM

Answers

  • How did you set the "redirection"?

    If you are using SharePoint 2010 server, you can set it in site settings->Welcome Page.

    If you are using SharePoint 2010 foundation, you can set the default page in SharePoint designer 2010.

    I don't think you need to change any setting in IIS manager.
    • Marked as answer by GuYuming Wednesday, August 17, 2011 1:23 AM
    Tuesday, August 16, 2011 7:31 AM
  • I understood that the issue was solved and closed. It was not marked as answer though.
    AK
    • Marked as answer by GuYuming Wednesday, August 17, 2011 1:24 AM
    Tuesday, August 16, 2011 11:12 AM

All replies

  • You probably do not have a SharePoint site at http://site.com/ and rather you have an IIS site. I am not sure if default documents in IIS can take care (you probably have default.aspx as a default document already). My suggestion is not to handle this from IIS but to create a simple site collection at / (root path) and put your redirection there (on any page you specify as home).
    AK
    Wednesday, August 10, 2011 10:20 AM
  • Hi AbedKhooli, Thank you very much for your reply. I have my sharepoint site @ http://site.com/en and http://site.com/ is my site collection. I renamed the default in the sitecollection and it takes the default document specified in the IIS. Thanks alot.
    Wednesday, August 10, 2011 12:05 PM
  • How did you set the "redirection"?

    If you are using SharePoint 2010 server, you can set it in site settings->Welcome Page.

    If you are using SharePoint 2010 foundation, you can set the default page in SharePoint designer 2010.

    I don't think you need to change any setting in IIS manager.
    • Marked as answer by GuYuming Wednesday, August 17, 2011 1:23 AM
    Tuesday, August 16, 2011 7:31 AM
  • I understood that the issue was solved and closed. It was not marked as answer though.
    AK
    • Marked as answer by GuYuming Wednesday, August 17, 2011 1:24 AM
    Tuesday, August 16, 2011 11:12 AM