none
I can't download apps to my phone

    Question

  • Hello,

    I was in the middle of a Windows 10 phone application deployment when it failed. The errors were:

    Error : DEP6100 : The following unexpected error occurred during bootstrapping stage 'Connecting to the device '30F105C9-681E-420b-A277-7C086EAD8A4E'.':
    1>SEHException - External component has thrown an exception.
    1>Error : DEP6200 : Bootstrapping 'Device' failed. Device cannot be found.

    Attempts to correct the situation included re-starting Visual studio (several times), re-booting the computer (several times), re-booting the phone (several times), re-registering the phone (once), and re-loading Visual Studio (once). Nothing has worked, the error persists.

    On the first re-boot of the computer I learned it was in the middle of an update (why are you updating at 11:00 AM while I am developing?). Upon completion the re-boot came up in the BIOS screen informing me I had installed a new processor - wrong! F10 to save - continue re-booting 20 minutes later (after all updates finished) same problem exists.

    I have now exhausted all attempts that I know of but one, remove the latest update, which I will try now. Any suggestions?

    Chris

    Wednesday, November 18, 2015 1:00 AM

Answers

All replies

  • Hi no_one_special,

    Which version of Visual Studio are you using? Does this problem just occur with this specific Windows Phone app?

    Please create a new Windows Phone app to make sure whether this problem occurs with all project. If it just occurs with the specific project, please create a new project and then move all file to the new one.

    If for all project, please try with below steps to troubleshooting your problem.

    1. Since your computer do an updating when you first re-boot, please update your Visual Studio too. VS2012 need to install Update 4, VS2013 need Update 5. If any other version, please feel free to let me know.
    2. Right-click the connection icon in taskbar and select the show devices and printers option. When it opens, you will see all the windows phone devices you have connected to the computer. Disconnect your device and uninstall it and its drivers. Then connect the phone again, which will install the phone connection and its drivers again.
    3. Please deploy this app to another phone or to the Windows Phone Emulator to confirm this problem is caused by the phone or not.

    If above steps still can't solve this problem, please check the Output windows to get more detailed information about this problem.

    Best Regards,
    Weiwei

    Wednesday, November 18, 2015 6:40 AM
    Moderator
  • Answer to your first question - VS2015

    Answer to your second question - yes, deployment to the desktop window appears to be working.

    I created the new app - same problem exists. However, a new data point has arisen. In the new app I tried to create a button in XAML and the design viewer said it could not find an IPC port, and the design viewer did not show, instead a list of errors culminating with 'cannot find IPC port'.

    Response to your first suggestion - 2015 is fully updated (not using 2012 as you inferred)

    Response to your second suggestion - did that, no change

    Response to your third suggestion - did that, no change

    Anything else?

    Wednesday, November 18, 2015 6:15 PM
  • Hi no_one_special,

    According to your description for your test step, this problem is caused by Visual Studio 2015. This problem is occurred after updating your Windows.

    I suggest you repair your Visual Studio 2015 through steps of Control Panel -> Visual Studio 2015 -> Change -> Repair.

    In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio. Please upload the ActiveLog.xml file to OneDrive and share the link here. We will analysis this file to check what happened when the problem occurred.

    Best Regards,
    Weiwei

    Thursday, November 19, 2015 1:32 AM
    Moderator
  • I am not going to as asked because I went much farther than asked. I re-installed Windows 10 Pro and VS20015 - and the problem is still preset. This precludes, or at least should preclude, any bad registry settings, files, etc leaving only the phone, the project, and the BIOS. I did find some articles on other having this issue and solving it in the BIOS. However, they also claim it was solved with firewall settings, wifi settings, and similar settings.

    Since you are unsure of what to do, I will pursue these avenues first, before coming back to you.

    Thursday, November 19, 2015 4:53 PM
  • Hi no_one_special,

    Which version of Windows 10 SDK and the version of your Phone?

    If your Emulator and Windows 10 SDK version is 10240, please install the latest version of Emulator and Windows 10 SDK.

    Lastest Emulator and SDK:

    https://dev.windows.com/en-us/downloads/windows-10-developer-preview

    Then install the UWP Tools 1.1.1 with following thread guidance, which introduce how to install UWP Tools in different scenario.

    https://social.msdn.microsoft.com/Forums/en-US/73f2d56d-9e8e-4b57-bcfa-0a972dfd75d7/update-11-generating-store-associated-package-fails-for-a-uwp-application-with-a-winrt-component?forum=Win10SDKToolsIssues

    After above installation, please reboot your computer and then deploy your app to Emulator and Device again.

    Best Regards,
    Weiwei

    Friday, November 20, 2015 2:36 AM
    Moderator