Error 25015 while installing .NET Framework 2.0 RRS feed

  • Question

  • Hi,

    I have a problem getting NetFX 2.0 installed.

    While installing the framework with Elevated Rights I get :

    Error 25015: Failed to install assembly 'C:\WINNT\Microsoft.NET\Framework\v2.0.50727\Microsoft.VisualBasic.Vsa.dll' because of a system eror: Access is denied.

    If I give the user admin rights the installation works fine.

    Is there a way to get around the admin rights, I really dont want to get it to all 2000 users on our site :-)


    /// Johan

    Monday, January 2, 2006 12:05 PM


All replies

  • You need to be an admin to install the framework.

    If you're deploying the framework via SMS or active directory, follow the steps in the admin deployment guide.

    The admin gude is in the \setup folder of VS.  It's called adminreadme.htm

    Wednesday, January 18, 2006 1:00 AM
  • I am suffering the same problem, and I logged in as an admin

    Wednesday, January 18, 2006 3:11 PM
  • Anyone find a solution to this yet? We've been tring for months and nothing works.


    Tuesday, March 21, 2006 4:32 PM
  • Can you zip up the installation logs in your %temp% directory and send me an email from my blog?


    I'll reply with an email you can send the logs to.


    Wednesday, March 22, 2006 12:30 AM
  • Monday, April 3, 2006 8:31 PM
  • Sorry, But I don't see how that is helpful.

    Unless I got a bad link.

    I am an administrator, and I don't have the service referenced installed.  I do have Symantec Anti-virus.


    I could use any help.


    Thanks, Brian

    Friday, April 21, 2006 6:40 PM
  • Hi everybody.  I'm sorry but I just want to have my PDA working again.  I keep on getting this message

    Error 25015. Failed to install assembly ‘C:\WINDOWS\Microsoft.NET\Framework\v2.050727\Microsoft.VisualBasic.Vsa.dll’because of system error: 0x80131107.  

    Can somebody help? please I'm desperate ! Smile Smile

    Sunday, May 13, 2007 1:23 PM
  • Hi everybody.  I'm sorry but I just want to have my PDA working again.  I keep on getting this message

    Error 25015. Failed to install assembly ‘C:\WINDOWS\Microsoft.NET\Framework\v2.050727\Microsoft.VisualBasic.Vsa.dll’because of system error: 0x80131107.  

    Can somebody help? please I'm desperate ! Smile Smile.  You may contact me at carolthemermaid@msn.com

    Sunday, May 13, 2007 1:23 PM
  • Hey Whats up im Luis and i cant understand how to solve this problem. please can someone help me?
    Wednesday, May 23, 2007 1:49 AM
  • Hi,

    I got the same problem while I was installing it. I went to the


    directory and deleted the


    folder. Afterwards I just reinstalled it and no problem anymore. Hope this will also work in your case Wink



    • Proposed as answer by Fqb1 Thursday, July 10, 2008 6:12 AM
    • Marked as answer by Figo Fei Thursday, December 11, 2008 4:07 AM
    Saturday, July 14, 2007 4:30 PM



    Thank you landero 2 weeks of trying to figuer it out and boom install niceley

    thank you so much


    Regards jam201984

    Thursday, August 2, 2007 8:42 PM
  • Grazie Landero! senza il tuo utilissimo consiglio non sarei mai riuscita a d installare Autocad!

    Grazie infinitamente!

    ero arrivata alla frutta ma per fortuna ho incontrato il tuo messaggio!

    Thank you!


    Saturday, August 4, 2007 12:46 PM
  • could someone say if, after trying my solution, he or she is still coping with the same problem?

    or is it solved? If not I will try to find an other solution.





    Tuesday, August 7, 2007 7:53 PM
  • Hi Landero,

    Same problem here.
    Also after I deleted folder "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727".

    Anyone who could help me out?


    I've downloaded the dotnetfx_cleanup_tool and I used it, now I can install all frameworks, 1.1, 2.0, 3.0 and higher.

    Download it here: http://astebner.sts.winisp.net/Tools/dotnetfx_cleanup_tool.zip
    Friday, August 10, 2007 8:30 AM
  • Thanks Landero  worked great!!!!!!


    Sunday, August 12, 2007 4:16 AM

    I'll try to find something else for you Rulez....
    Sunday, August 12, 2007 3:44 PM
  • Thank you!  I have been fighting this for two days. Neither Microsoft support nor Dell could help me. Thank you!

    Wednesday, August 15, 2007 2:40 AM
  • Go to


    and then delete this file v2.0.50727 and the try the intall again it helped for me

    Thursday, August 16, 2007 11:01 PM
  • I found this post whilst looking for the reason .NET 2.0 Framework was failing to install.


    All I did to make it work was temporarily disable my antivirus for the install duration - and it worked fine!  Not the most elegant solution, I agree, but it seems to work - unusual as MS usually put something in at the start regarding disabling AV software if you're required to do so.


    Ah well - installed and the world is a happy place once more!

    Friday, August 17, 2007 11:25 AM
  • Really thanks,Landero!

    I had fixed the same problem.

    Saturday, August 18, 2007 11:08 AM

    Thanks a lot Landero...Fix my problem and headache
    Monday, August 20, 2007 2:57 AM
  • Landro, pure genius....works great!!!
    Thursday, August 23, 2007 5:56 PM
  • Thanks for saving me hours and not being angry at my dogs.

    Friday, August 24, 2007 4:10 PM
  • Thanks, Landero!


    That took care of the problem.


    Friday, August 24, 2007 4:56 PM
  • oh realy you fixed the problem right i knew the awnser all ready to your fix anit to hard

    Sunday, September 9, 2007 10:24 AM
  • What do you mean, "Afterwards I just reinstalled it...."?  I need directions on "reinstalling" it.

    Sunday, September 9, 2007 1:58 PM
  • Hi Mordido,


    "I got the same problem while I was installing it. I went to the


    directory and deleted the


    folder. Afterwards I just reinstalled it and no problem anymore.



    with that "afterwards...." i meant that you just rerun your setup, or how should i call it... just run the  '.net Framework 2.0' setup if you got that one in a separate file. if not you can always download it (ill give you the link http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5 (english file but you can switch the language)


    Hope this will help you to fix your problem






    Monday, September 10, 2007 5:37 PM





    THANK U !

    Friday, September 14, 2007 11:37 AM
  • Worked tremendously.  It was driving me crazy, the drivers and software for my ATI 1950Pro graphics card would not install properly and gave numerous errors because of this simple problem.


    Thank you so very much for finding the solution, I cannot begin to express how much I appreciate it.






    Saturday, October 6, 2007 4:40 PM

    Landero...  You are the man! That's the ticket.  Simple but effective solution


    Don Heinsen

    Tuesday, November 6, 2007 7:37 PM
  • thanks mate. saved me a  lot of trouble
    cheers Big Smile
    Friday, November 9, 2007 10:29 PM
  • I had the same problem trying to install framework 2 0r 3 and deleted the v2.050727 folder and everything worked fine.  Thank you very much


    Saturday, November 17, 2007 11:09 PM
  • I'm trying to install this yet >Error 25015: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Vsa.dll' because of system error: The system cannot find the path specified< keeps popping...

    Tried landero's suggestion and the clean up tool yet both failed. Any other solutions?
    Saturday, November 24, 2007 9:41 PM
  • I tried the suggestions of Landero and any combination thereof for a while, sure I have some corupted files here and there from my last hdd crash. I tried:


    Erasing:  C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727

    Clean Up: dotnetfx_cleanup_tool

    Running dotnetfx from a C:\temp directory

    Erasing the content of one of my \TEMP directories 


    Just before giving up I tried the suggestion of Aaron Stebner Solving setup errors by using the SubInACL tool to repair file and registry permissions. I downloaded the Windows Resource Kit named SubInACL, see




    So I ran: SubInAcl, erased: \Framework\v2.0.50727, ran: dotnetfx_cleanup_tool, finally: dotnetfx from the C:\temp and it worked. Thanks for keeping the tread alive, owe you a pizza all of your!

    Wednesday, November 28, 2007 2:06 PM
  • My Error 25015 said "device not ready", before I ran the cleanup tool.  Now Framework 2.0 is installed.  Thanks, Rulez.
    Sunday, December 9, 2007 9:42 PM
  • Thank you very much Lanredo, this was the solution to the problem.

    Thursday, December 13, 2007 6:22 PM
  • Thanks Landero,

      It worked beautifully.  I need to install the updates nowSmile


    Saturday, December 15, 2007 12:24 PM
  • omg i struggled with this for the last 48 hours after using hp pc system recovery to restore my computer to its original factory settings and drivers. after this i reupdated windows xp through windows update. then i downloaded dotnerframe work 2.0 because i needed to install my ati hd2600xt agp card but it didn't want to. to many errors. googled it and finally came across with Landero's solution. thanx

    Wednesday, December 19, 2007 4:49 PM
  • Hi,

    I got the same problem while I was installing it. I went to the


    directory and deleted the


    folder. Afterwards I just reinstalled it and no problem anymore. Hope this will also work in your case



    This worked perfect for me thank you

    Saturday, December 29, 2007 9:14 PM

    Just want to say that Zicc's method worked for me when all else (deleting the folder as suggested by another user) failed. Cheers
    Tuesday, January 1, 2008 11:02 PM
  • Just a thanks to Lando...this was THE answer
    Saturday, January 5, 2008 1:56 AM
  • Hi Landero,

    same problem but cannot delete v2.0.50727

    popup says cannot delete TBD1E tmp  ...access is denied. Make sure sidc is not full or write protected or currently in use.

    Does it make any difference if NET framework 1.1 is deleted before u start or after, or don't u delete it t all.

     It won't let me delete it anyway.

    hope u will reply

     kind regards


    Wednesday, January 9, 2008 7:36 AM

    Friday, January 25, 2008 1:26 AM
  • deleted the


    Thanks! That fixed my problem!   I wasted many hours before I noticed your post!



    Thursday, January 31, 2008 8:23 AM
  • After hours of trying things to fix this problem with no luck, I found this forum and a simple little delet and reinstall fixed the problem.



    Sunday, February 3, 2008 6:33 PM
  • hi


    got the same problem while I was installing it. I went to the


    directory and deleted the






    Tuesday, February 12, 2008 2:48 PM


    directory and deleted the







    SWEETLUSH I GIVE YOU 5***************************

    Tuesday, February 12, 2008 2:55 PM
  • I have been struggling with this problem for days.  I tried several other recommendations.  This was the first that worked.  Thanks!!!!!


    Friday, February 29, 2008 9:43 PM
  • kept getting an error that different files during the install were being used, disabled my security suite Comodo and it installed!

    ty for the advise
    Friday, March 7, 2008 8:40 PM
  • I got the error 25015 problem during a crashed installation of dotnet 3.5

    I tried all the solutions given but nothing worked. Removal tool, renaming dir's, the subinacl tool, removing dll's, Aaron Stebners wisdom and more.

    In the end i tried a rollback (system restore) to a previous state BEFORE i installed dotnet. This worked. There is some software i had to reinstall because of the rollback, but this still is a lot better than installing xp again.
    Maybe this solution is to obvious so no one mentioned it before, but it saved me al lot of trouble.



    ps making images of your configuration more often is also a good idea (in retrospect)
    Wednesday, March 12, 2008 2:03 PM
  • I got the same error (Error 25015. Failed to install assembly ‘C:\WINDOWS\Microsoft.NET\Framework\v2.050727\Microsoft.VisualBasic.Vsa.dll’because of system error: 0x80131107) when installing 2.0 .NET framework.


    Deleting the directory v2.050727 helped me solve the problem. Thank you for that great suggestion.

    Friday, March 28, 2008 9:30 AM
  • Thank you Landero. For some reason, I ran into this problem when trying to load TurboTax, which tried to install .NET. It was great to find this easy solution.

    Monday, April 14, 2008 11:19 PM

    I used the link you provided and was then able to download .net framwork 2.0 without any problems.


    Monday, May 26, 2008 3:01 PM
  • I wanted to thank you for sharing that tip! I really helped me out a lot.
     so a great big hug and kiss for you ;-)

    Thursday, July 10, 2008 6:11 AM
  • Hey Landero... I tried your method and it worked on solving the error. BUT BEFORE I SAY THIS NO-ONE LAUGH, the second i did that and retried installation, it switched from one error to the next, first the error 0x80131107 then access is denied... When i saw that i tried all other methods, the one by aaron failed. I don't know why, instead of the software giving me elevated rights nothing happened. Cleanup tool did nothing, same goes for MSCONFIG method, and all the other numerous things. I even disable antivirus but to no luck. If there is anyone ot there who can fix my problem, you deserve to own microsoft, their software is good but too many errors.
    Monday, September 1, 2008 4:10 PM
  • HI i am trying to install MS .net frame work 2

    i am getting the following error msg

    Error 25015. Failed to install assembly ' C:\WINDOWS\Microsft.NET\Framework\V2.0.50727\Microsoft.VisualBasic.Compatibility.dll" because of system error: 0x80131107

    please advice.


    Saturday, October 11, 2008 5:05 PM
  • Thank you Landero, I deleted the folder you mentioned and it work form me... I reallay appreciate all of you guys for posting solutions for some of us who really would not know what to do..

    Thanks a million.
    Friday, February 6, 2009 5:54 PM
  • Hey!
    After three hours of misery I did this and it worked! YAHOO! THANK YOU, THANK YOU THANK YOU!
    Monday, April 6, 2009 9:24 PM
  • You rule man thanks a ton

    Aman Dass
    Wednesday, April 15, 2009 11:39 PM
  • This did not work on my system. I am running Windows XP media center.
    Sunday, September 6, 2009 3:24 PM
  • This is for Vista only
    Sunday, September 6, 2009 3:28 PM
  • I tried to do it thee way you suggested, but then I get another error message saying that the file for c:\windows\microsoft.net\framework cannot be found, and I have also tried to reinstall it and it still won't let me.  The reason I am working with the framework is because I had printer problems.  Everytime I would try to install a printer, it would come up saying the print processor is not available.  Then when I would try to download and install this, it would come up saying that the .net framework cannot be located.

    Please somebody help me install the .net framework file and also the print processor.  Thank you all so very much.

    Saturday, October 10, 2009 4:54 AM
  • Thank you,worked perfectly.
    Saturday, November 7, 2009 11:14 AM
  • Ziccs,

    You are the man. Following your steps fixed it for me.
    Friday, January 8, 2010 4:11 PM
  • Thank you Landero

          That did it

    Monday, January 18, 2010 8:23 PM
  • Landero,

    So glad I found this post! It worked...thank you!!!!!

    Friday, February 12, 2010 12:09 AM
  • If ALL above fails then rename :c/windows/assembly. Rename it to something like Assembly_ and then the installation will work!
    • Proposed as answer by Kobbe Tuesday, March 23, 2010 5:11 PM
    Wednesday, March 10, 2010 8:02 PM
  • i have been trying for weeks now to get the net frame work to install,i have tried every suggestion in these forums and nothing works i can install the net frameworks up until net framework 2 then it won't install any more i am running windows xp service pack 3, i was thing should i remove the service pack 3 and reinstall it as i think i might have some files missing somewhere
    Tuesday, March 23, 2010 3:02 PM
  • So, have you have tried to rename the :c/windows/assembly map to something different and then installing .net framwork 2.0?
    Tuesday, March 23, 2010 5:12 PM
  • no i haven't tried that yet ,how do you do that
    Tuesday, March 23, 2010 8:49 PM
  • i just done a search for the :c/windows/assembly file and it came up as an invalid file
    Tuesday, March 23, 2010 10:13 PM
  • The map is called assembly and not "c/windows/assembly", that is the whole path.




    1. Open "this compuer"/"computer"

    2. Open C drive

    3. Open "windows" map

    4. Rename the folder called Assembly to another name.

    5. Install .net framework 2.0



    Before: :c/windows/assembly

    After: :c/windows/oldassembly

    • Proposed as answer by Kobbe Wednesday, March 24, 2010 2:21 PM
    Wednesday, March 24, 2010 2:20 PM
  • Thank you landero, it worked perfectly!!

    thanks again,

     Regards drk9luver

    Monday, March 29, 2010 3:58 AM
  • Thank you so much this fixed my problem trying to install the Kodak 5250 all in one printer.  Now works a treat. thanks..
    Monday, March 29, 2010 8:53 PM
  • Landero, I'm glad that your post was still here after all this time...  I was getting the 0x80131107 error when trying to install .NET Framework 2.0...


    I found your post here and, after doing everything else that everyone said to do, I followed your instructions and Poof...  I now have .NET Framework 2.0...


    I hope they leave your post here till the ink fades away....lol


    You were a great help and I for one, REALLY appreciate your post and you....  Thanks.....

    Monday, April 12, 2010 8:18 PM
  • Landero, your solution of deleting the directory v2.050727 worked like a charm!!

    I've been trying to install Framework 2.0 for the past 7 months (and spent many hours on it today) and your suggestion was the magic fix.  

    NOTE:  I suggest that renaming that directory rather than deleting it (just in case this fix doesn't work you can go back and rename it to it's orginal name without having lost anything).  I renamed mine to "v2.050727XXX".

    Cheers to everyone and I wish yaw'll the best of luck with your issues!

    Btw, if it makes any difference, I was installing the 32 bit dotnetfx.exe on my XP.
    Saturday, April 24, 2010 8:29 PM
  • This worked for me too.
    Saturday, May 15, 2010 5:15 PM
  • THANK YOU SO MUCH!!!! it worked better then i thought! points to u man!!!!
    Wednesday, June 2, 2010 10:11 PM
  • Kobbe, you are great! I tried to fix the problem for several days and nothing, but u help me to fix it! 

    P.S. I had a massege "Error 25015.Failed to install assembly 'C:\windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Vsa.dll' because of system error: The system cannot find the path specified"

    Thank you million times!

    Friday, June 18, 2010 9:54 PM
  • Your solution worked. Thanks!!!!


    Friday, July 2, 2010 7:39 PM
  • Thank you very much Landero.

    Never taught it would work.

    Sunday, July 4, 2010 4:56 PM
  • Thank you, Landero. I followed your advice and was able to successfully complete the installation.



    Tuesday, August 31, 2010 8:40 PM
  • Just thought I'd post this solution to my problem that has taken me 2.5 days!!

    I could not install .net 3.5 as it was crashing when trying to install .net 2

    I was getting:
    error 25015 failed to install assembly system.messaging
    in the log was a message:
    ***warning***: cannot obtain mscoree.dll version at c:\windows\system32\mscoree.dll"
    and crashes involving:
    visualstudio8setup (even though this wasnt installed anymore)

    Tried .net cleanup tool, asl resetting tool, etc was at the end of my tether, thinking about a fresh install of windows XP, then I did this and it worked:

    rename C:\WINDOWS\assembly to C:\WINDOWS\oldassembly

    Warning, this is a bit drastic: I wouldn't be surprised if that broke any .net apps you have so you would have to reinstall etc.
    Friday, December 31, 2010 2:38 PM
  • Landero,

    Don't know if ur still out there but a million thanks for your suggestion!


    Monday, January 31, 2011 6:32 PM
  • Thanks Landero,

    After so many years I was able to find your post and it worked perfectly!

    Friday, April 22, 2011 2:54 PM
  • After 2 months of trial and error, blogs, support pages and prayer,  this is the only thing that worked.

    Thank you for giving me my life back!

    Sunday, August 14, 2011 1:42 PM
  • It was resolved for me after I disabled Anti Virus software and retried installation.


    Friday, February 17, 2012 8:39 PM
  • Thank YOU   Thank YOU!!!!  This worked for me - I am having problems with installing NET. 3.5 I wonder if I delete that folder if it will help with that as well.  I may just give it a try!!!
    Saturday, February 18, 2012 12:56 AM
  • Landero,

    I had the same problem and went to a website that said to uninstall and reinstall all net framework applications.  I uninstalled 4, 3.5, 3, and 2 and when I followed your suggestion all the applications were still listed in the framework folder.  I deleted 2.0 and tried reinstalling it and it worked.

    Wednesday, February 22, 2012 7:19 PM
  • Thanks Landero. I went to  "C:\WINDOWS\Microsoft.NET\Framework" and deletedthe folder 'v2.0.50727' (which holds dot.net 2 data) - after this it installed no problem. Thanks
    Sunday, September 15, 2013 3:15 AM
  • I tried EVERYTHING in this topic! disabling AV AND deleting the folder, I STILL get the error "Error 25015.Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.VisualBasic.Vsa.dll' because of system error: Access is denied." NOTHING WORKS!!! what else???
    Saturday, March 21, 2015 1:45 AM