locked
How can i set xamarin uwp app icon RRS feed

  • Question

  • User351573 posted

    Hi, I am trying to set xamarin uwp app icon. Set all the icons in Package.appxmanifest --> Visual assets --> App icon. Here is the screenshot:

    But no changes in the default xamarin icon!!! Any solutions? Thanks in advance :)

    Monday, January 22, 2018 11:53 AM

Answers

  • User89714 posted

    @Sreeee - If using VS2017, using the Generate button in the Asset Generator section of the Visual Assets tab of the Package.appxmanifest populates the images used for the various icons. If that's not working for you, can you show a screenshot and highlight where you are still seeing the Xamarin icon (is it top left on the title bar or the app, or on the task bar usually at the bottom of the screen).

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, January 22, 2018 12:26 PM

All replies

  • User89714 posted

    @Sreeee - If using VS2017, using the Generate button in the Asset Generator section of the Visual Assets tab of the Package.appxmanifest populates the images used for the various icons. If that's not working for you, can you show a screenshot and highlight where you are still seeing the Xamarin icon (is it top left on the title bar or the app, or on the task bar usually at the bottom of the screen).

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, January 22, 2018 12:26 PM
  • User351573 posted

    @JohnHardman said: @Sreeee - If using VS2017, using the Generate button in the Asset Generator section of the Visual Assets tab of the Package.appxmanifest populates the images used for the various icons. If that's not working for you, can you show a screenshot and highlight where you are still seeing the Xamarin icon (is it top left on the title bar or the app, or on the task bar usually at the bottom of the screen).

    Initially, I manually create icons for different resolutions. I don't know this generate option. Thanks for this information :)

    Monday, January 22, 2018 1:01 PM
  • User89714 posted

    @Sreeee - It seems to be a new addition. It wasn't there when I first added my UWP assets. I've just used it to regenerate the assets, but have subsequently put back my old splash screen images, as the automatic generation created the central part smaller than I like.

    Monday, January 22, 2018 1:03 PM